Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
Read about Qlik’s Response to COVID-19 Read the Letter, Join the Group.
Highlighted
New Contributor II

General Script error

Hello All

While reading data from QVDs I am getting the "general script error".

below is the log related to the same script.

 

LEFT JOIN (MAINTABLE)
LOAD ABC as ABC,
EFG as EFG
FROM $path\XYZ_DIM.FULL.qvd(qvd)
2 fields found: ABC, EFG,
1,325,426 lines fetched
Joining/Keeping
General Script Error
Execution Failed
Execution finished.

Tags (1)
1 Solution

Accepted Solutions
Highlighted
New Contributor II

Re: General Script error

Checked the data model, there were circular loops in it, removed them, issue is fixed.

Thanks for the suggestion

View solution in original post

9 Replies
Highlighted
Valued Contributor III

Re: General Script error

Hi Deepak,

 

 

I Have couple of guesses on this General Error:

load application under debug mode  10 records each 
load tables one by one (probably also in debug) and see where the error incurs
Some times Join also cause  
does it always happen on the same table? if you change the order of loading?
do you have the rights to read in the database?

So please check all these conditions else if possible share entire Script so that our folks will help you ASAP.

 

Highlighted
New Contributor II

Re: General Script error

Thanks for replying Ramana

No, this is the first time i am facing this issue.

There were few changes i made in the script:

1) added a table to pull few columns from it

2) added 2 additional columns from an existing QVD

Highlighted
New Contributor II

Re: General Script error

Please put ; after From statement and try loading

Highlighted
New Contributor II

Re: General Script error

I checked the script and already have ; after the from statement
Highlighted
Honored Contributor II

Re: General Script error

is there any message during script reload if you put:

Set ErrorMode =1;

at the beginning of your Load?

Highlighted
New Contributor II

Re: General Script error

I can see Set ErrorMode =2 in the log of QVW that failed. What does it mean??

Highlighted
Honored Contributor II

Re: General Script error

Somewhere in your script is the following line :

Set ErrorMode = 2

Change it to

Set ErrorMode = 1

and have a look at the errormessage appearing when reloading script!

 

From Qlikviw Help:

ErrorMode 

This variable determines what action is to be taken by QlikView when an error is encountered during script execution. 

By default (ErrorMode=1) the script execution will halt and the user will be prompted for action (non-batch mode). 

By setting ErrorMode =0 QlikView will suppress all error messages on failure to load. If script execution is halted due to failure, it will not continue.

By setting ErrorMode =2 QlikView will trigger an "Execution of script failed..." error message immediately on failure, without prompting the user for action beforehand. 

Example:

 set ErrorMode=0;
Highlighted
Partner
Partner

Re: General Script error

hello, 

try give the fields other names then the one they already have

Highlighted
New Contributor II

Re: General Script error

Checked the data model, there were circular loops in it, removed them, issue is fixed.

Thanks for the suggestion

View solution in original post