Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
Modernize Your QlikView Deployment webinar, Nov. 3rd. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

HTTP URL is giving error 404

Hello All,

I've made an application in which multiple links i've given ,if some one click on link then a csv file should download .

But problem is  in access point when application is open and on hitting url error 404 is coming.

I have attached screen shot.

Please tell me what setting i need to make.

Links.PNG

URL is 'http://server I.p./D:/BI/Development/02-Data/CSV/'

P.S. I am using I.E.

Thanx in advance

5 Replies
Highlighted

Not sure. but have you tried to put those CSV files into the server and check it?

Instead of absolute path, give the relative path link

Highlighted

URLs typically do not allow you to point to files in a Windows file system (some web sites may not even run on a machine with a 😧 drive). This is a very old 90's security mechanism to avoid publishing your OS files on the external internet.

The browser is not important, as demonstrated by the error message 404 which means that the web server cannot find the page you are requesting. All pages on a web site are either located in the directory tree under the document root or URLs are disassembled by web server code to lead to a location in a DB. QlikView servers use the classical document root-based page location.

Which web server is your QlikView installation using?

QVWS: check the different document locations accessible by QVWS in QMC->System->Setup->QlikView Web Servers->Web->Root Folders. Anything in folders not under these starting points cannot be made available via the AccessPoint

You can either relocate the documents you want to publish, or add a Root Folder that points to the correct location.

Best,

Peter

Highlighted
Not applicable

Thanku for ur support Settu but those CSV files are already in server and path which i've given is server folder path.

Highlighted
Not applicable

Thanx for your answer Peter , same application is running on different server but I don't know what settings they made.

I am using Qlikview Web server.

I've Added a root folder which is pointing CSV file Location. but still getting same error.

I can't move those CSV because those are generating when data model runs.

root.PNG
Thanks

Highlighted

The link to your files now become for example http://server ip/CSVREPORT/csvfile.csv

Replace csvfile.csv with the correct file name for each different link.