Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

pieter_kouyzer
New Contributor

Hide GeoAnalytics Layer Boxes in Qlikview

Hi all,

I have a question regarding the use of GeoAnalytics for Qlikview.

I have a GeoAnalytics map with several layers displaying information on that map (an area layer, a bubble layer and a line layer). Each of these layers displays perfectly fine. However for each layer I also have a box which I can use to set properties, see a simple legenda etc. I would prefer if these boxes are hidden for users, whilst the layers remain unhidden.

I have thought of hiding the boxes behind another object and setting that other object to the 'top' layer, but when I turn WebView on, the top/bottom indication is instantly forgotten. WebView has to be turned on in order to see the map and layers however.

Any suggestions are welcome.

Thank you,

Pieter

1 Solution

Accepted Solutions
justinvchiang
New Contributor III

Re: Hide GeoAnalytics Layer Boxes in Qlikview

Oh I see, I mistakenly thought the boxes were separate objects but it sounds as if they are an attribute to the layer like a legend.

I don't know of a way to dynamically show/hide a legend (though in most charts you can just turn it on or off).

For your object overlay idea, have you tried to use a custom layer rather than top/bottom?  The Top/Bottom settings are a little buggy in my experience, but maybe setting the layer to 10 might work.

View solution in original post

5 Replies
justinvchiang
New Contributor III

Re: Hide GeoAnalytics Layer Boxes in Qlikview

One thing I've done is implemented a 'Maintenance Mode' in my APPs where certain sheets or sheet objects only appear based on the environment the APP is opened in.

For example, if you have a DEV environment and a PROD environment you could have your additional boxes show only when in DEV so that you can see them but when your APP is deployed end users will not see them.

This variable can be set using something like this in your load script:

LET vEnvironment = GetRegistryString('HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment', 'QV_ENVIRONMENT');

Then it's just a matter of setting conditions on the objects to be hidden such as vEnvironment = 'DEV'.

If you don't have multiple environments you can still do something similar with a more binary approach such as setting a vShow variable to 1 if OSUser() matches to whatever your user credential is and set it to 0 for everyone else.  Or if you're using a service account, this could be done using an Admin role.

pieter_kouyzer
New Contributor

Re: Hide GeoAnalytics Layer Boxes in Qlikview

Hi Justin,

Thank you for your response!

I think this is a really good best practice and something I'll definitely use, but I'm afraid it does not solve my problem. As the layers in the map will be hidden when the box belonging to that layer is hidden, this would cause my 'PROD' environment to have those layers missing which are in fact necessary for the user.

I hope this explains it clearly, I'm not sure how to better describe it.

Regards,

Pieter

justinvchiang
New Contributor III

Re: Hide GeoAnalytics Layer Boxes in Qlikview

Oh I see, I mistakenly thought the boxes were separate objects but it sounds as if they are an attribute to the layer like a legend.

I don't know of a way to dynamically show/hide a legend (though in most charts you can just turn it on or off).

For your object overlay idea, have you tried to use a custom layer rather than top/bottom?  The Top/Bottom settings are a little buggy in my experience, but maybe setting the layer to 10 might work.

View solution in original post

pieter_kouyzer
New Contributor

Re: Hide GeoAnalytics Layer Boxes in Qlikview

Hi Justin,

I've gone for the object overlay idea and with your custom layer (I set it to 100 just to be sure) the boxes remain hidden behind the other object. So problem solved, I'd say. Thank you for your help!

Pieter

justinvchiang
New Contributor III

Re: Hide GeoAnalytics Layer Boxes in Qlikview

Great!  Glad to hear it worked.