Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Highlighted
Not applicable

How to Clear Current Box Selection

Hi All,

I have a filter, where the options are A and B.

The Current Selection Box is displaying the value, even after clicking the Clear Selection option.

By default, it is displaying either A or B.

Can anyone help me with this?

Thanks,

Praveen

Message was edited by: Praveen Kumar Updated

20 Replies
Not applicable

Re: How to Clear Current Box Selection

May be that Filter is Locked...Right Click on that filter--->Un Lock and Click Clear

or

There is one dropdown Arrow near Clear Button...Click that dropdown you can find "Unlocak and Clear All" select it...

Thanks,

Selva

MVP
MVP

Re: How to Clear Current Box Selection

And, check if the 'Always One Selected Value' in general tab is checked. You have to uncheck that.

Edit: You might have to check if there is any hidden list boxes that are selected with same check mentioned above.

Not applicable

Re: How to Clear Current Box Selection

Hi Selva,

Thanks for your reply.

But, I didn't enable any lock options.

The filter which I have created is by using inline function only.  May be is that a problem ?

Not applicable

Re: How to Clear Current Box Selection

No its not an issue at all.. Are you using any On Open or On Active Trigger for that field?.. Or check "Always One Selected Vale" as mentioned by tresesco...

Not applicable

Re: How to Clear Current Box Selection

Hi Tresesco,

Thanks for your reply.

I have selected 'Always One Selected Value' .  The Thing is if I uncheck the box, it is showing as two tabs also to be selected.

Not applicable

Re: How to Clear Current Box Selection

Selva,

I am not using that Trigger options.

Not applicable

Re: How to Clear Current Box Selection

Hi Tresesco,

PFA

Not applicable

Re: How to Clear Current Box Selection

Hi Selva,

PFA

MVP
MVP

Re: Re: How to Clear Current Box Selection

PFA

Your dimensions of the charts were conditional in enablement (removed that)

Update: If you want that condition to be there then try second attachment.