Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Highlighted
bhaveshp90
Contributor III

How to resolve this error?

Hello, 

I have a table as shown below;


1.PNG

 

 

 

 

 

 

 

 

I have my expression as;

=If(Header_1 <> 'Curr.to OEC',
Rangesum(sum({<Snapshot_Date = {">=$(=Date(Addmonths(Max({1} Snapshot_Date),-2), 'YYYY-MM-DD'))"}>}POC_Adjusted_Value_USD)),

(

RangeSum(sum(TOTAL<Region, Month,  Country_Name, Snapshot_Date, Report_Param>{<Header_1 = {'Curr.mth.'}, Snapshot_Date = {">=$(=Date(Addmonths(Max({1} Snapshot_Date), -2), 'YYYY-MM-DD'))"}>}POC_Adjusted_Value_USD))
-
RangeSum(sum(TOTAL<Region,Month,Country_Name,Snapshot_Date,  Report_Param>{<Header_1 = {'Upd.OEC'}, Snapshot_Date = {">=$(=Date(Addmonths(Max({1}Snapshot_Date), -2),'YYYY-MM-DD'))"}>}POC_Adjusted_Value_USD))
)
)

 

This expression is working but when the values are same it is showing as null, look at the highlighted value in the image (182.378 - 182.378 = -)

 

Why is my value showing as - instead of  '0'? any help is greatly appreciated. 

 

thanks

Bhavesh

 

Labels (3)
1 Solution

Accepted Solutions
Partner
Partner

Re: How to resolve this error?

Hi,
I got the solution, in "Presentation" tab, there is "Suppress Zero-Values".
After you cancel it, you can see 0 values.
Aiolos
4 Replies
Partner
Partner

Re: How to resolve this error?

Hi Bhaveshp,
It will be better if you can upload a small sample, so I can try to find out what the problem is.
Have you tried to add num() function for the rangesum()?
Aiolos
bhaveshp90
Contributor III

Re: How to resolve this error?

@uacg0009 I have tried Num() also but I'm not getting '0'. Please see the attached qvw for your reference

1.PNG

 

 

 

 

 

 

 

Partner
Partner

Re: How to resolve this error?

Hi,
I got the solution, in "Presentation" tab, there is "Suppress Zero-Values".
After you cancel it, you can see 0 values.
Aiolos
bhaveshp90
Contributor III

Re: How to resolve this error?

thank you @uacg0009