Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Highlighted
bhaveshp90
Contributor III

How to solve this issue ?

Hello,

I have a table as shown below:  

1.PNGMy goal is to get the Schedule flag from "FACT Schedule" Tab as highlighted in yellow below;

2.PNG

 

 

 

 

 

 

 

 

 

I tried all ways to link them in the script (data model) when I select [New_Area] field the [SCH Schedule Flag] data is not responding as shown below (I think because [New_Area] & [SCH Task Discipline] is not connected)

Capture.PNG

 

 

 

 

 

 

 

 

 

 

My desired output should be like this:

when I select "MECHANICAL ENG" in [New_Area]12.PNG

when I select "SOFTWARE ENG" in [New_Area]13.PNG

 

 

when I select "CONTROLS ENG" in [New_Area]

14.PNG

 

 

Sorry for the long post,  I tried all the ways and checked with all my sources but couldn't able to get the desired output.

Could anyone help me? I sincerely thank you again for all your valuable time and help. Attached are the files for reference

 

thanks again

Bhavesh

 
  •  
Labels (1)
1 Solution

Accepted Solutions

Re: How to solve this issue ?

Can you check the attached

5 Replies
MVP
MVP

Re: How to solve this issue ?

I think the cardinality of your link fields and link tables is wrong. If you select a single Link_Key_SAP_ORA or Link_Key_SAP_SCH value, you get multiple values on both sides of the link.This is why it looks like New-Area and SCH_schedule Flag are not associated.

Do you really intend this to be a many-to-many association? I think you model design needs to be reconsidered.

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein

Re: How to solve this issue ?

Can you check the attached

bhaveshp90
Contributor III

Re: How to solve this issue ?

Awesome @sunny_talwar , this is exactly what I want. thank you very much. 

I see that you removed the Cost_area field from 1st table, now my POC expression is not working 

POC = Actual Cost/Projected Cost (do not filter Cost area, which means it includes all Actual and Projected costs from Cost Area)

num(
(Sum({1<[SCH Task Discipline], [ORA DAY VERSION]={">=$(vCurrentMonthStart)<=$(vCurrentMonthEnd)"}>}[ORA Actual])
/
Sum({1<[SCH Task Discipline],[ORA DAY VERSION]={">=$(vCurrentMonthStart)<=$(vCurrentMonthEnd)"}>}[ORA Projected])
)
,'##0%')

Can you tell me what should I change in my above expression? 

 

thanks again 

 

Re: How to solve this issue ?

What was it giving before? What is it giving now? What does it suppose to give?

bhaveshp90
Contributor III

Re: How to solve this issue ?

@sunny_talwar  I've posted in another forum as this has been closed. Please look into this question https://community.qlik.com/t5/New-to-QlikView/Expression-is-not-populating-for-all-project-numbers/t...

 

thanks again