Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

ddm_it_account
New Contributor

Issue QV 12.10 SR8 expression - referencing another column's name

Hey community,

I have recently upgraded our QlikView Server and Desktop Client to version 12.10 SR8

After the upgrade I have noticed that using the name of columns in the expression of other columns is not working anymore.

See example below, where the expression Price * 0.1 returns Nulls

Capture.JPG

When changing the expression to column(1) * 0.1, I get the expected result.

Capture1.JPG

Any thoughts about why using the Name of the column is not working?

Many thanks,

Carmen

4 Replies
martinpohl
Valued Contributor II

Re: Issue QV 12.10 SR8 expression - referencing another column's name

do you have a field in your data model named price?

I've recognized also

mgavidia
Contributor

Re: Issue QV 12.10 SR8 expression - referencing another column's name

Try putting the column name between squared brackets::

[Price]*0.1

I also have version 12.10 SR8 and for me it works either way:

sergio0592
Valued Contributor II

Re: Issue QV 12.10 SR8 expression - referencing another column's name

Try with : "Price"*0.1

Highlighted
ddm_it_account
New Contributor

Re: Issue QV 12.10 SR8 expression - referencing another column's name

Dear All,

Thanks for your help. I did some more tests and it seems that the Problem happens in only documents with Direct Discovery.

In other documents where Direct Discovery is not used, I can create expressions based on the labels of other expressions with no Problem.

 

Could you guys please make a test as well and check if you can use labels in expressions in a document with Direct Discovery?

 

Many thanks,

Carmen

Community Browser