Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
Modernize Your QlikView Deployment webinar, Nov. 3rd. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Creator II
Creator II

Keeping straight table size fixed

After making certain selections straight table size changes and keeps on increasing or dcreasing even if move/size option is unchecked. Is there any way to keep the table size fixed?

16 Replies
Highlighted
Creator II
Creator II

Hi Jagan,

I tried that still it does not work..column size changes

Highlighted
MVP & Luminary
MVP & Luminary

Hi,

There is no option to restrict column size, based on the data qlikview dynamically sets the column width.  Size to data is for fixed Table size.

If your entire column has fixed number of characters then column size won't changes.

Regads,

Jagan.

Highlighted
MVP & Luminary
MVP & Luminary

Hi Rohan,

Click on the Row Header between the two cells, the width will adjust based on your data, so that width wouldn't change.

or

Right click on the table and select

FIT Column to Data option


Regards,

Jagan.

Highlighted
Contributor III
Contributor III

Hello Rohan,

even if this post is a little older, I want to tell you my experience and workaround. I had the same problem with a straight table. I got 40 dimensions and just 2 expressions and my table width was more than 3500 px. I tried all the things that were mentioned here but nothing worked.

So I found out that it is not possible to  decrease the size of a straight table when the reason for the width are the dimensions. So I changed my table into a table with just 5 dimensions and 37 expressions. I just put any dimension in an expression. And after that i could move the size.

Maybe it's a workaround for you as well.

Best regards.

Theresa

Highlighted
Not applicable

Hi Jagan,

I'm facing problem with straight table.

I have created a straight table with 2 dimensions and one expression.

When I select any value's(row) in  straight table, it automatically shrinks to that particular selection.

I want, it has to be selected, but not to be shrink, it has to show all the values.

Is there any possibility for this.

Thanks in Advance.

Regrads,

Pavan.

Highlighted
MVP & Luminary
MVP & Luminary

Hi,

Uncheck Size to Data in Layout tab.  Hope this is what you expects.

Regards,

jagan.

Highlighted
Partner
Partner

This worked for me! Thanks !