Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Highlighted
Not applicable

Legends not being shown in line chart

I have a line chart contained within a container. I have two expressions. I have assigned a custom color to each expression. Lines are displayed correctly in the chart. In expressions tab I have option "expression as legend" checked for both expressions but legends are not being displayed.

1 Solution

Accepted Solutions
Partner
Partner

Re: Legends not being shown in line chart

goto your Chart and press Strg+Shift

you will see boxes surrounded by red lines

move these boxes (especialy the box which seems to be empty - that one of expressions)

and try to move, Change size

maybe you thelegend is outside of visible area

4 Replies
MindaugasBacius
Valued Contributor III

Re: Legends not being shown in line chart

Check if this tick is on:

Screenshot_1.jpg

Partner
Partner

Re: Legends not being shown in line chart

goto your Chart and press Strg+Shift

you will see boxes surrounded by red lines

move these boxes (especialy the box which seems to be empty - that one of expressions)

and try to move, Change size

maybe you thelegend is outside of visible area

Not applicable

Re: Legends not being shown in line chart

Yes, it is checked.

Not applicable

Re: Legends not being shown in line chart

Yes, this was the problem, legend was outside. I have changed size, but my legends appears vertical and I want to be horizontal. I solved this by moving, resizing and finally legend was put horizontal automatically. Thanks.