Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
Make your voice heard! Participate in the 2020 Wisdom of Crowds® Survey. BEGIN SURVEY
Highlighted
Siva_Sankar
Honored Contributor

Metadata handling not working properly

Hi,

I have gone through Handling Metadata in QlikView  by sinanozdemir   and when I try to implement it ,it works for some tables and not for some.

I have attached a application.

Can any one look and see and let me know why is it?

Regards,

Sivasankar

32 Replies
Highlighted

Re: Metadata handling not working properly

Please check the attached.

I think order of loading table should be the same as in inline table.

Highlighted
MVP & Luminary
MVP & Luminary

Re: Metadata handling not working properly

Hi,

In QV 11.2 SR9 it is not working as expected even changing the order.

Regards,

Jagan.

Highlighted

Re: Metadata handling not working properly

I am using 11.2 SR12 and it is working for me

Highlighted
MVP & Luminary
MVP & Luminary

Re: Metadata handling not working properly

Even the alternate method is also not working for ASCII and Transactions tables

Comment Table Characters with 'Contains Characters';

Comment Table ASCII with 'Contains ASCII Values';

Comment Table Transactions with 'Contains Transaction Facts';

Comment Table Dummy with 'dummies values';

Highlighted

Re: Metadata handling not working properly

Have you tried opening the QVW which I have attached?

Highlighted

Re: Metadata handling not working properly

I guess the problem must be in the below statement in the Characters table.

Load Chr(RecNo()+Ord('A')-1) as Alpha, RecNo() as Num autogenerate 26;

If you change the Alpha to some other name then it's working fine.

Capture.PNG

Check the attachment.

Highlighted
MVP
MVP

Re: Metadata handling not working properly

It seems the Characters table, when i change the load script of that table, it starts working; see attachment

1.png

Highlighted
Siva_Sankar
Honored Contributor

Re: Metadata handling not working properly

Its not working in my existing dashboard even after changing the order and other suggestions.

Version I am using Qv 11 SR 12

Highlighted

Re: Metadata handling not working properly

Did you check the attachment.?