Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
QlikWorld, June 24-25, 2020. Free virtual event for DI and DA gurus. Register Now
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor

Missing data after loading to Qlikview

Hello Experts,

I am extremely new to Qlikview and is only able to produce some simple charts and tables.

But I run into a problem that, there are some data that is missing after I load from excel (xlsm file) to Qlikview.

Specifically,

I only have 5 Columns.

Year, Month, P&L, Product Type, Segment

I fully loaded all these columns onto there and tried to plot a line chart.

with Dimension of Month, against the Expression -- SUM of P&L

Surprisingly, I realise the total numbers shown on the line chart (where i point my cursor to) shows a total number of Dec (and other months too) does not match the total number of Dec (and other months too) on Excel.

After a long investigation, I see all across the months, it has only shown the SUM of P&L for three out of five of the Product Type

Any thoughts please?

I would love to share my file but its in the office...which I dont have access to now.

5 Replies
Highlighted
Master
Master

Re: Missing data after loading to Qlikview

Tough to guess without data but whether your file is having P&L for all the months?

what are the dimensions?

Highlighted
Contributor
Contributor

Re: Missing data after loading to Qlikview

Hello,

Thank you for your reply,

Yes I have P&L for all months,

like this

YearMonthP&LProduct Type
2017Jan1000000A
2017Jan2000000B
2017Jan3000000C
2017Jan4000000D
2017Jan5000000E

I have my dimension as "Month"

My Expression as "P&L"

So I have 12 data points on my graph, each of them represents their respective month

But very weird that, each of my data point only shows the sum of Product B C & D, for example, in the above table, I get January number as 9,000,000, which it should be 15,000,000

I hope this is more clear, thank you!

Highlighted
Contributor II
Contributor II

Re: Missing data after loading to Qlikview

Is there a way to connect with you Joe?

Highlighted
Contributor
Contributor

Re: Missing data after loading to Qlikview

Yes, please add me on telegram?

Telegram: Contact @ysoseriouss

Highlighted
Master
Master

Re: Missing data after loading to Qlikview

Can you share the complete data?