Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Not applicable

Missing value from chart

Hello,

I have a problem with a chart.

It don't display the values because there are 2 values for the specific field. And I have a '-' symbol instead.

It is something that I can do ? Or the problem is from the data files ?

Thanks,

Claudiu

1 Solution

Accepted Solutions

Re: Missing value from chart

Hi Claudiu, if there are more than one value, you should tell QV what to do with those values, if it's a number you can use Sum(), Avg()... If it's a string you can use MinString(), Concat()...

First you need to decide wich value you want to be shown and why, then you can tell if the problem was on data files or if you want to solve that in script during reload or in chart while execution time.

If you don't solve how to treat several values, QV returns a Null(), usually represented by '-'.

View solution in original post

2 Replies

Re: Missing value from chart

Hi Claudiu, if there are more than one value, you should tell QV what to do with those values, if it's a number you can use Sum(), Avg()... If it's a string you can use MinString(), Concat()...

First you need to decide wich value you want to be shown and why, then you can tell if the problem was on data files or if you want to solve that in script during reload or in chart while execution time.

If you don't solve how to treat several values, QV returns a Null(), usually represented by '-'.

View solution in original post

Highlighted
Not applicable

Re: Missing value from chart

Thanks a lot for your answer. I inserted a CONCAT() function, and now it's like I want it. Thanks!