Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Multiple selection issue in Trigger

Hello,

I am trying to set up a trigger in document properties and facing this issue with multiple selections using trigger.

I have 2 fields by name product 1 and product 2 in listbox.

when I make a selection in product 1 ( say A) and set a trigger on it to select the same value in product 2 it works.Thr product 2 also shows as A.

But when I make more than one selection in product 1( say A,B,C,D) , the product 2 does not even show a single value as selected under it.

It seem slike the trigger fails when we make multiple selections or selections where the data is not a direct text value match.

Could anyone help resolve this issue? Its been annoying for last 2 days.

Thanks.

1 Solution

Accepted Solutions
nagaiank
Valued Contributor III

Re: Multiple selection issue in Trigger

Attached is a solution to your problem. Note the search string expression for the document trigger for the first listbox field.

Hope this helps.

8 Replies
nagaiank
Valued Contributor III

Re: Multiple selection issue in Trigger

Attached is a solution to your problem. Note the search string expression for the document trigger for the first listbox field.

Hope this helps.

Not applicable

Re: Multiple selection issue in Trigger

Hi Krishnamoorthy,

This works perfectly.

However one additional point.

In the current selection box the selected items are displayed with in brackets and separated by pipes.

Is there a way to avoid it and just display them separated by commas?

I have attached the pic for reference. Here in the pic as you see the Model is separated by pipe and included within brackets.pic3.jpg

Please let me know.

nagaiank
Valued Contributor III

Re: Multiple selection issue in Trigger

I tried to solve your problem using macro.

In the attached example, I have defined three listboxes for fields Prod1, Prod2, and Prod3.

If you select one or more values in the listbox for Prod1, the same values will be selected in the other two listboxes.

For Prod2, I have used 'Select in Field' in the trigger. But this method does not show the selection(s) for Prod2 in the current selections box like the selections for Prod1.

For Prod3, I have used a macro to duplicate the selections. By this method, current selection box display for Prod3 is similar to that for Prod1.

If your environment allows use of macros, you may use that approach, if you are very particular about the contents of the current display box.

Not applicable

Re: Multiple selection issue in Trigger

Hi Krishnamoorthy,

Many thanks for the help.

~Sabertooth

flyingcheesehea
Contributor II

Re: Multiple selection issue in Trigger

Krishnamoorthy,

That's a great solution - Unfortunately, it does not appear to work for multiple text values. If I select a single value in the trigger field, it selects the corresponding value in the other fields (I need it to select in two other fields). However, if I select multiple values in the trigger field, I get no selections at all in the other two fields. Any idea how to fix this?

Thanks,

Kent

bradleyfairclot
Contributor

Re: Multiple selection issue in Trigger

NagaianK,

I used your solution for a month to fiscal period trigger and it works great. However when I select more than six months it turns from the periods selected to NOT the periods that I did not select which makes the trigger ineffective. Any idea why this occurs, and a way that I can correct it? Any further help you can offer on this will be greatly appreciated.

nagaiank
Valued Contributor III

Re: Multiple selection issue in Trigger

Please attach your application with listbox values and trigger requirements so that we can arrive at a fix.

bradleyfairclot
Contributor

Re: Multiple selection issue in Trigger

Here you go. Thanks for your help.

Community Browser