Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

domiho123
Not applicable

My Google Map is too static

Hi all,

I am fresh at QlikView. I have followed the Designer Course last week and would like to build an application that integrates Google Maps. After browsing through different posts and in different example files, I still cannot have my copy work. I have attached my example, build in a personal edition however. Can anyone point out what is wrong with my file?

Thanks in advance!

1 Solution

Accepted Solutions
erich_shiino
Not applicable

My Google Map is too static

Hi, Dominique.

Since you are using personal edition, I will not post your example back, but please, check the number format of your 'Longitude'.

You can try this:create a new table box and include the fields: Inwoners, Latitude and Longitude.

You will see that the field Longitude was not recognized as a number, but as a text due to the dot as the separator.

You can try to fix it at the souce, or use num# to force the interpretation of your number. using num#() function:

num#(Longitude, '#,##.##', '.', ',')

Your load script would look like this (more or less) :

LOAD Plaats,

     Startlocatie?,

     Inwoners,

     num#(Longitude, '#,##.##', '.', ',') as Longitude,

     Latitude,

     Jaar,

     Maand,

     Seizoen

FROM

Vakantiebestemmingen.xls

(biff, embedded labels, table is Vakantieplaatsen$);

Hope this helps,

Erich

3 Replies
erich_shiino
Not applicable

My Google Map is too static

Hi, Dominique.

Since you are using personal edition, I will not post your example back, but please, check the number format of your 'Longitude'.

You can try this:create a new table box and include the fields: Inwoners, Latitude and Longitude.

You will see that the field Longitude was not recognized as a number, but as a text due to the dot as the separator.

You can try to fix it at the souce, or use num# to force the interpretation of your number. using num#() function:

num#(Longitude, '#,##.##', '.', ',')

Your load script would look like this (more or less) :

LOAD Plaats,

     Startlocatie?,

     Inwoners,

     num#(Longitude, '#,##.##', '.', ',') as Longitude,

     Latitude,

     Jaar,

     Maand,

     Seizoen

FROM

Vakantiebestemmingen.xls

(biff, embedded labels, table is Vakantieplaatsen$);

Hope this helps,

Erich

dennisnet
Not applicable

My Google Map is too static

Hi Dominique

Erich is right it has something to do with the number format.
As you can see in your data, your Latitude has comma's and your Longitude has dots.

If Enrich's solution is not working try to play around with the following in your load script:

    Replace(Latitude   , ',' ,  '.' ) as Latitude,

    Replace(Longitude , ',' ,  '.' ) as Longitude

This will replace the comma's for dots.

Or the other way around (depending on your settings):

    Replace(Latitude   , '.' ,  ',' ) as Latitude,

    Replace(Longitude , '.' ,  ',' ) as Longitude

Mocht het niet lukken laat het dan even weten.

Succes.

Dennis.

domiho123
Not applicable

My Google Map is too static

Guys,

Thanks for your input. It is working now. The problem was indeed related to . and , and on top the coordinates were not translated correctly.

Regards,

Dominique.