Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
mazacini
Contributor III

One value of dimension displays as Null (-) in Chart

I am lading a field in my script as follows:

 

if(len(Start)>0,(-((year(Order_Entry_Date)*12)+month(Order_Entry_Date)) + ((year(Start)*12)+month(Start))),Num(9999)) as

Leadm

It seems to work fine. My list box for the dimension displays as follows:

Dim as Nill 1.PNG

However, when I include Leadm as a dimension in a chart, the value 9999 is rendered as '-', as shown below

Dim as Nill 2.PNG

Any ideas?

Rgds

Joe

1 Solution

Accepted Solutions
MVP
MVP

Re: One value of dimension displays as Null (-) in Chart

Could you please check that 9999 is really replaced by '-'  in the dimension, by selecting 9999 in the list box (should result in the one '-' line table) and by deselecting option suppress zero values in presentation tab.

How is your InvVal calculated and how are all fields used related?

2 Replies
MVP
MVP

Re: One value of dimension displays as Null (-) in Chart

Could you please check that 9999 is really replaced by '-'  in the dimension, by selecting 9999 in the list box (should result in the one '-' line table) and by deselecting option suppress zero values in presentation tab.

How is your InvVal calculated and how are all fields used related?

mazacini
Contributor III

Re: One value of dimension displays as Null (-) in Chart

Hi Stefan

When I selected 9999, there were NO dimensions / data displayed on my table.

I think you are suggesting that the problem lies in my model.

I have made some mods and the problem seems to be sorted.

Thanks for poinitng me in the right direction.

Joe

Community Browser