Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Pop up labes in Gauge chart

Hi,

I have multiple gauge charts with different expressions. Lets take this expression for example:

 

Productief: AVG(VERLOFAFGEBOEKT) / 8

Sometimes when some values are selected a gauge charts shows the message 'No data to display'. To get rid of that message and instead let it show null i add this expression:

alt (Productief, 0)

This solution works however there is one problem. When i mouse over the pointer of the gauge chart it doesnt't show the right value. If for example the result is '171' the pop up label shows '17171,298...'.

Does somebody know a solution?

1 Solution

Accepted Solutions
Not applicable

Re: Pop up labes in Gauge chart

I found something that does solve the problem a little so for the ones that have the same problem:

I changed the 2nd expression in: alt(' Days').

Then i marked the 'text as pop up' checkbox. Now when there is 'No data to display' it shows '0 Days', and if the result is for example 15 it shows '15 Days'.

Not excactly what i wanted but sure good enough. :-)

3 Replies
Not applicable

Re: Pop up labes in Gauge chart

try  : alt(AVG(VERLOFAFGEBOEKT)/8, 0)


Not applicable

Re: Pop up labes in Gauge chart

Thanks for your quick response. Its still the same with that expression. If the result is '15' it shows '1515' and so on.

Not applicable

Re: Pop up labes in Gauge chart

I found something that does solve the problem a little so for the ones that have the same problem:

I changed the 2nd expression in: alt(' Days').

Then i marked the 'text as pop up' checkbox. Now when there is 'No data to display' it shows '0 Days', and if the result is for example 15 it shows '15 Days'.

Not excactly what i wanted but sure good enough. :-)