Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

daniel_degrille
New Contributor II

QMC with SSL/https

Hello Community,

is there a possible way to start the QlikView Management Console with https instead of http (by using the port 4780)?

like this:

https://xxxx:4780/qmc/SystemSetup.htm

Or, should I integrate it in IIS like the QVWS?

https://xxx/qlikview/index.htm

Our config:

In our Company we use a three Tier Layer for Qlikview:

Tier 1: Presentation Layer = IIS+QMC.

Tier 2: Application Layer = QDS,DSC,QVS

Tier 3: Database Layer = SQL-Server

Communication from Intranet to Presentation Layer must be secured.

Yours Sincerely Daniel

Tags (3)
1 Solution

Accepted Solutions
daniel_degrille
New Contributor II

Re: QMC with SSL/https

Hello tresesco,

thanks for your post. But there are info's about how to redirect to Accesspoint, not to QMC.

Now we have solved it.

1. In IIS\Sites\Bindings:

      Add port 4780 (there ist port 443 for Accesspoint to).

2. In D:\QlikView\Management Service\QVManagementService.exe.config

     Change UseHTTPS from false to true:

     <add key="UseHTTPS" value="true"/>

View solution in original post

3 Replies
MVP
MVP

Re: QMC with SSL/https

daniel_degrille
New Contributor II

Re: QMC with SSL/https

Hello tresesco,

thanks for your post. But there are info's about how to redirect to Accesspoint, not to QMC.

Now we have solved it.

1. In IIS\Sites\Bindings:

      Add port 4780 (there ist port 443 for Accesspoint to).

2. In D:\QlikView\Management Service\QVManagementService.exe.config

     Change UseHTTPS from false to true:

     <add key="UseHTTPS" value="true"/>

View solution in original post

nihalbuddy09
Contributor II

Re: QMC with SSL/https

Hi Daniel,


Need your help to start the QMC by using https. I have tried your suggested steps but still it's opening in http instead of https.


I have installed the QV Server and created the SSL by following Enable SSL - QlikView Webserver

and Access Point is working with https.

For QMC, added the port 4780 and also made changes in the config file but still unable to open QMC by using https. In Config file I already have "true" so only made changes and replaced 'http' as 'https'.... did I miss anything over here.

Please advise.

Thanks,

Nihal