Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
IMPORTANT: Upcoming LEF Database Maintenance, Oct. 3rd - SEE DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor II
Contributor II

QVConnect "Failed To Start Connector"

Hi folks. Just installed Qlikview at work and I'm having trouble using QVConnect to attach to my SQL Server based databases. QVConnect appears to reside in an AppData Local folder which must have some sort of permission on it as QVConnect (both 32 and 64bit versions) is repeatedly reporting "Failed to start connector" when I try to create a connection string. Is there any way I can move QVConnect to a different folder and inform Qlikview or is there some other workaround? Very eager to start using it and this is a stumbling block. 

16 Replies
Highlighted
Contributor II
Contributor II

"Unblundling" directory is right! I'm a busy boy - as, I suspect, are most of Qlikview's users - but I'll try to submit a ticket if I can get round to it. Many thanks for your support on this issue.

Highlighted

If you can find the time, you can also talk to a Qlik representative and make them aware of the Sales opportunity, if this problem can be resolved first. After what you told us, I'm sure you'll get a speedy reply.

Highlighted
Contributor II
Contributor II

   Hi guys,

I opened a case on french Qlik Support. No good news, Cf. https://qliksupport.force.com/articles/000045498 (requires login).

In a few sentences :

"If there is a security protection (such as a group policy or antivirus) that block file execution from this path, QlikView is unable to run these exe files and shows error "Failed to connect to Qlikview Connector"

Currently this path is hardcoded, so it is not possible to configure QlikView to pick up another path."

My answer to Qlik Support below. I'll tell you if there's some news.

Bye for now.

   Bonsoir,

Merci beaucoup pour le temps que vous avez accordé à mon problème. Je n'avais pas lu l'article que vous mentionnez mais j'avais bien identifié un problème de droits d'accès (Cf. https://community.qlik.com/message/1452822#1452822).

Le choix qu'a fait QlikTech pour gérer l'exécution de QVConnect est surprenant et particulièrement gênant. Pourquoi avoir changé et codé en dur le chemin jusqu'à QVConnect ???

Le nouveau chemin choisi porte le numéro de version de QV (12.20.20400). Est-ce que ça signifie qu'il faudra demander à lever des restrictions de stratégie de groupe à chaque future installation d'une nouvelle version de QV ? Ca n'a pas de sens.

Je ne souhaite même pas solliciter mon équipe informatique à ce sujet; les restrictions actuellement en place au sein de l'entreprise l'étant pour des raisons réfléchies que je ne souhaite pas perturber.

C'est avec résignation et une déception certaine que je vais installer une précédente version de QV sur mon poste. Au moins, je sais qu'elle fonctionnera correctement et sans artifice.

Si vous pouvez transmettre mon désarroi et celui d'autres utilisateurs (Cf. Anthony ici : https://community.qlik.com/thread/295718) à QlikTech pour les faire réagir et proposer un patch, je vous en serai reconnaissant.

Bien cordialement,

   Jean-Eric

Highlighted
Contributor
Contributor

The following helped me: I moved temp\qvconnect folder to another location, create a link to this folder in temp. Everything works without administrative rights.

Highlighted

FYI: when scanning the release notes for the last few QlikView SRs (looking for a possible fix for something else), I noticed this amongst the QlikView November 2017 SR7 bug fixes:

"Failed to connect to QlikView Connector" or "Failed to unbundle QVConnect" error

messages shown in QlikView due to group policies.

Jira issue: QV-14723

It seems that Qlik has fixed someting related to the unbundling issue. Has anyone been able to resolve this problem using SR7?

Highlighted
Creator
Creator

Knowing that the QvConnector is embedded within the exe (version 12.2) my only option is to exclude this process within my virus protector settings.

Using the info from the 'even log'  , I've added the 'Process signed info'  the be excluded in my anti-virus  program. That solved my problem.

Highlighted
Creator III
Creator III

Hi Peter,

I tested with a limited user account on QV November 2017 SR6, the connection was successful without any error.

I guess the issue might have been sorted by the Qlik team.