Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Giovane
New Contributor III

QlikView 12.40.20100.0 Version - DB Conecction in Trouble

I downloaded QlikView 12.40.20100.0 version, and my db connections started to fail, as you can see bellow:

clipboard_image_1.png

The ODBC conecction is working propperly, as shown bellow:

clipboard_image_2.png

is this a QV version problem? Have someone the answer for this issue?

 

 

1 Solution

Accepted Solutions
Giovane
New Contributor III

Re: QlikView 12.40.20100.0 Version - DB Conecction in Trouble

Guys, just to close the subject: I reinstalled the QlikView version, the same version witch caused the problem, and the problem has gone!!! 

Thanks to Jobson by his interest and attention.

 

View solution in original post

7 Replies
jobsonkjoseph
Contributor III

Re: QlikView 12.40.20100.0 Version - DB Conecction in Trouble

Hi,

Are you using any connection string to get connected to the db.

Giovane
New Contributor III

Re: QlikView 12.40.20100.0 Version - DB Conecction in Trouble

Are you talking about the string connection into the QV script, such as shown bellow?

clipboard_image_0.png

jobsonkjoseph
Contributor III

Re: QlikView 12.40.20100.0 Version - DB Conecction in Trouble

it'll be like this;

OLEDB CONNECT32 TO [Provider=NZOLEDB;User ID=;Data Source=;Initial Catalog=;Mode=ReadWrite;Port=5480;SSL Security Level=0;SSL CA Certificate File="";Logging Level=0;Log Path=C:\;Packet Size=32768;Optimize for ASCII=0] (XPassword is );

 

check whether you are giving all the values properly. above is sample only.

Giovane
New Contributor III

Re: QlikView 12.40.20100.0 Version - DB Conecction in Trouble

Hi, Jobson...

Originally I was using an ODBC connection. As the connection has failed after I updated to the 12.40.20100.0 version, I changed the connection to OLE DB, as you showed before. Connection problem was solved. But, the beneath question persists? Why after update QlikView version to 12.40.21100.0 version did the problem appear? Is ODBC connection not available for this version? What is the relation between 12.40.20100.0 version and ODBC connection? Is it a version bug?

jobsonkjoseph
Contributor III

Re: QlikView 12.40.20100.0 Version - DB Conecction in Trouble

Hi Giovane,

I've not got a chance to try ODBC connection, so unsure of it not working in this release.

But OLEDB works fine. May be the qlik support has a answer to your question.

Giovane
New Contributor III

Re: QlikView 12.40.20100.0 Version - DB Conecction in Trouble

Thanks for you attention, Jobson. You've got the point, my problem is not for doing QlikView to connect to the DB, my problem is why the ODBC connection does not work with 12.40.21100.0 version. Is someone else facing the same problem as mine? Have anyone else some ideia about the question?

One more time, thank you Jobson.

 

Giovane
New Contributor III

Re: QlikView 12.40.20100.0 Version - DB Conecction in Trouble

Guys, just to close the subject: I reinstalled the QlikView version, the same version witch caused the problem, and the problem has gone!!! 

Thanks to Jobson by his interest and attention.

 

View solution in original post