Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
QlikWorld, June 24-25, 2020. Free virtual event for DI and DA gurus. Register Now
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor III
Contributor III

QlikView 12 and AllowDataLineage = -1 (disable)

Hello,

we have updated our QlikView Server and QlikView Desktop to version 12.

It looks like that "disable the Lineage data" in the qvd files not working.

I have test it with the QlikView Destop and AllowDataLineage = -1 setting like it works in the 11 version.

Can someone test it with the 12 version?

Regards, Henry

1 Solution

Accepted Solutions
Highlighted
Luminary
Luminary

Re: QlikView 12 and AllowDataLineage = -1 (disable)

I just updated a Customer server from version 11 to version 12.1 and the issue came back again.

Checked the setting.ini file on c:\windows\system32\config\systemprofileappdata\roaming\qlktech\qlikviewbatch and the parameter was there :  AllowDataLineage = -1. That is the option to disable it on Qlikview 11.


But something changed on Qlikview 12.1 and now it has to be AllowDataLineage = 0. After this change, the QVDs generated by publisher tasks now doesn´t have the lineage info anymore.


Regards, Pablo


View solution in original post

3 Replies
Highlighted
Luminary
Luminary

Re: QlikView 12 and AllowDataLineage = -1 (disable)

I just updated a Customer server from version 11 to version 12.1 and the issue came back again.

Checked the setting.ini file on c:\windows\system32\config\systemprofileappdata\roaming\qlktech\qlikviewbatch and the parameter was there :  AllowDataLineage = -1. That is the option to disable it on Qlikview 11.


But something changed on Qlikview 12.1 and now it has to be AllowDataLineage = 0. After this change, the QVDs generated by publisher tasks now doesn´t have the lineage info anymore.


Regards, Pablo


View solution in original post

Highlighted
Contributor III
Contributor III

Re: QlikView 12 and AllowDataLineage = -1 (disable)

Hello Pablo,

I "found" your message on the first working day of 2018. I have added/changed the line to AllowDataLineage=0 in the [Settings 7] section.

C:\Windows\System32\config\systemprofile\AppData\Roaming\QlikTech\QlikViewBatch\Settings.ini

C:\Users\UserName\AppData\Roaming\QlikTech\QlikView\Settings.ini

for QlikView Server and QlikView Desktop Client.

And it works 🙂

Happy new year and thanks for this info.

Regards, Henry

Highlighted
Luminary
Luminary

Re: QlikView 12 and AllowDataLineage = -1 (disable)

Glad it worked like a charm.

Happy new year !

Regards,

Pablo