Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
Modernize Your QlikView Deployment webinar, Nov. 3rd. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor III
Contributor III

Qlikview Desktop v Web

Like many I Develop in Qlikview desktop and then publish to Access point for Web access by the business.

I'm having a major issue with one of my dashboards in that the Web version is giving different results to desktop.  Both versions are the same qvw and selections on both are the same yet the web version seems to process differently giving different results.

This dashboard uses many expressions with multi states complicating it so I'm not looking to investigate all the expressions and methods used for this dashboard (it does work) but i'm looking for an explanation as to why the desktop and web versions of qlikview seem disjointed and produce different results for data processing and visually.  This seems to be a major bug with the platform which should be WYSIWYG.

Please see my example below of this issue;

This is a comparison report 3 different states are used for selection A, B and C the results are then presented together for the user to compare.  Results from groups A, B or C are conditionally shown if there are selections made under the group.

Below in Fig 1 is the selections made in Qlikview Desktop essentially compare sales on 24/12/2015 & 25/12/2015 to 24/12/2016 & 25/12/2016.  Correctly 4 dates are shown with 4 sales results

Qlikview Desktop.jpg

Below in Fig 2 is the selections made in Qlikview Web the same dates are selected 24/12/2015 & 25/12/2015 to 24/12/2016 & 25/12/2016.  In-correctly all dates irrelevant of selections are shown with sales results.

Qlikview Online.jpg

To further confuse things if in the web version I make a selection in Group C (an invalid 2017 date for instance) then the results are now correct!?!

Qlikview Online2.jpg

1 Solution

Accepted Solutions
Highlighted
MVP & Luminary
MVP & Luminary

Yes there is a potential conflicting by mixing different releases and therefore it's a recommendation of not doing it especially if it goes over major releases. What to do? It's difficult to advice - the easiest way seems to be to downgrade the client again but the server-release is with SR7 quite old (and as far as I remenber right was SR7 a bit buggy) and therefore an upgrade to a higher release might the more appropriate.

- Marcus

View solution in original post

4 Replies
Highlighted
MVP & Luminary
MVP & Luminary

Are the desktop client and the server on the same release?

- Marcus

Highlighted
Contributor III
Contributor III

Desktop is 12.0.20300.0 SR4 64bit

Qlikview server is 11.20.12451.0

You think this could cause the issues i'm experiencing?

Highlighted
MVP & Luminary
MVP & Luminary

Yes there is a potential conflicting by mixing different releases and therefore it's a recommendation of not doing it especially if it goes over major releases. What to do? It's difficult to advice - the easiest way seems to be to downgrade the client again but the server-release is with SR7 quite old (and as far as I remenber right was SR7 a bit buggy) and therefore an upgrade to a higher release might the more appropriate.

- Marcus

View solution in original post

Highlighted
Not applicable

Hi John,

Marcus is right. It is very important to maintain same versions on desktop and server.

I have had same issue like you. I upgraded the server to the latest version 12 release and it fixed the problem.