Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.


Qlikview ODBC write permissions?


I know QlikView is not done for Inserts into db but I have a strange issue to solve.

I'm trying to perform insertion into database, I have write permissions with my userid but when I launch the reload with QlikView the permission to write is denied.

I have the following error: 

"ODBC—call failed.
[IBM][System I Access ODBC Driver]Statement violates access rule: Connection is set to read only. (#30186)"


I've just put the settings like this but still doesn't work.


Is there additional settings or maybe someone  solved the same problem in the past?

Labels (1)
1 Reply

Re: Qlikview ODBC write permissions?

Alessandro, I think what you may be hitting is the 'Service Account' may be the one making the call here if you are running this via Publisher, I would expect Desktop should work provided you are logged in as you etc...  You may want to check IBM support too, as they may have something posted there on things as well given it may be the IBM Client Access driver doing something too.  It may be something along the lines of the driver is seeing the script as something different than a query from Excel etc. is all of which I can think.  I know the IBM drivers, like Oracle, tend to be very picky about things.  I know this is not much help, but hopefully will give you some other ideas.  If you do get it sorted, please post back what it was for others if you can, and if you do that, you can use the Accept as Solution button after you post to mark that as the solution as well, just FYI.


To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.