Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

shubham_kumar
Contributor III

Same Edit Module is not working for QVD load which works fine in SQL.

Hi,

I have a qvw file in two versions. One is SQL version and another is in QVD version. the VB script (edit module) is same for both. when we have put same on_open_document properties some specific field to select by default. it's working in SQL but the same code doesn't work in QVD. Could anyone will tell, what could be the reason?

Best Regards,

Shubham

Tags (2)
2 Replies
Not applicable

Same Edit Module is not working for QVD load which works fine in SQL.

Would you give the 2 codes ?

shubham_kumar
Contributor III

Same Edit Module is not working for QVD load which works fine in SQL.

Hi,

Below is the code I have used same in QVD and SQL but while opening in SQL that work and it select as Intended/wanted but in QVD it doesn't.

sub startup_selection
call select_last_pull
end sub

sub select_last_pull
set f = ActiveDocument.Fields("pull_type")
set fv = f.getnovalues
fv.add
fv(0).text = "last"
fv(0).isnumeric = false
f.selectValues fv
end sub

sub clear_all
activedocument.clearall true
end sub
sub run_on_open
call select_last_pull
call select_alc
call select_remove_0bdg_0cost
call select_last_pull_dates
end sub

sub select_last_pull_dates
ActiveDocument.Fields("PullCalendar.PullDateCY").clear
ActiveDocument.Fields("PullCalendar.PullDateLY").clear
ActiveDocument.Fields("ResactLY.Pull DateResAct").clear
ActiveDocument.Fields("Pull DateResAct").clear