Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

djaykumar
New Contributor

Section Access in Qlikview is not working

Hi All,

I am severely facing problem with Qlikview Section Access for data reduction.

I am using NTName and Department for data reduction. In Inline statement

Section Access;

LOAD * INLINE [

ACCESS,    NTNAME,       DEPARTMENT

ADMIN, Domain\Name,   *

USER1,Domain\Name,HR

USER1,Domain\Name,FINANCE

USER2,Domain\Name,CS

USER2,Domain\Name,CS-PARTS

];

Section Application;

And in the entire script made Department as uppercase. and checked 'initial data reduction based on section Access' and 'Strict Exclution'.

I have checked without giving  Section Access;  and Section Application;  I am getting correctly.

But I am getting all the above Departments for ADMIN,USER1 and USER2 (ie., everyone is able to see all the departments)

Its urgent.

Please help me.

Regards,

Jay

 

 

9 Replies

Re: Section Access in Qlikview is not working

Access field contain only 2 value
USER or ADMIN
not USER1 or USER2
Great dreamer's dreams never fulfilled, they are always transcended.
djaykumar
New Contributor

Re: Section Access in Qlikview is not working

Spoiler
Hi Prashant,

Thankyou for quick reply.

I have changed both USER1 and USER2 as USER.

But facing the same issue that all ADMIN and USERs are  able to see all the Departments. Data Reduction is not happening.
Please help me in this.

Regards

Jay

santhiqlik
Contributor

Re: Section Access in Qlikview is not working

Hi,

Have you checked the option "Strict Exclusion" in Opening Tab of the Document Properties in Qvw ?

djaykumar
New Contributor

Re: Section Access in Qlikview is not working

Hi Santhi,

yes I have checked 'Strict Exclustion'   in Opening tab of the Document Properties.

thanks

Jay

Re: Section Access in Qlikview is not working

do you have those value available in you data model on which you are implementing section access??
are all those value in caps?? try by Untick strict exclusion
Great dreamer's dreams never fulfilled, they are always transcended.
djaykumar
New Contributor

Re: Section Access in Qlikview is not working

Hi,

Yes I made the fields of Department as upper case in entire application and tried by uncheck 'Strict Exclusion'.

But facing the same problem getting all departments in ADMIN as well as USERS.

Thanks,

Jay

anushree1
Valued Contributor

Re: Section Access in Qlikview is not working

the code seems all fine.

But, how are you checking on the access ;has any other user logged onto the app in the server as a user and not admin and checked for what departments are available.

 

Highlighted
Partner
Partner

Re: Section Access in Qlikview is not working

Hi,

are the field and the values of DEPARTMENT in your datamodel also exists and are they in upper cases also?

Regards

Support
Support

Re: Section Access in Qlikview is not working

Here are some links that should help you sort things out:

http://help.qlik.com/en-US/qlikview/November2018/Subsystems/Client/Content/QV_QlikView/Security.htm

https://community.qlik.com/t5/Qlik-Design-Blog/A-Primer-on-Section-Access/ba-p/1465766

On the second link, there are further links to other Section Access related blog posts, three of them, so be sure not to miss those as well.  I think this should be a good start for you to confirm everything.

One thing I do when I am troubleshooting Section Access and DDR, is comment the Section Access line of the script, leaving the load statements etc., this way you will be able to see the Section Access table in the Data Model Viewer to see how things are linking to ensure you have that part working correctly, and you can then also use some List Boxes to further troubleshoot things as well...  Hopefully this helps you move things forward here.

Oh, one other thing, be sure you read up on the meaning of * in the reduction field versus no value, you are going to want to be sure anybody you want to see 'everything' gets a no value, as * only includes values loaded for the other users, so if you have some values that are not associated with any users, those would never appear etc.  This something that is commonly missed.  The catch though is that any users with no value and strict exclusion enabled, will NOT be able to open the application via QVServer, only Desktop with the Admin Override option set...  

Regards,
Brett

To help users find verified answers, please don't forget to mark a correct resolution or answer to your problem or question as correct.