Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Not applicable

Section Access using a QVD file with a combination of userID, password and NTName

Hi,

I've having some problems with Section Access which works fine if I use a excel workbook or inline load as the data source but when using a QVD file it doesn't want to play.

I'm using a combination of USERID, PASSWORD & NTNAME and my qvd file looks like this:

USERID PASSWORD NTNAME ACCESS GROUPSECURITYLINK
ADMIN ADMIN * ADMIN
CALLCENTRE\RICHARD.PEARCE ADMIN

This is the script which generates it:

TeamLeader_SectionAccess:
LOAD * Inline [
USERID, PASSWORD, NTNAME, ACCESS, GROUPSECURITYLINK
ADMIN, ADMIN, *, ADMIN,
,,CALLCENTRE\RICHARD.PEARCE,ADMIN,

];

Store TeamLeader_SectionAccess into TeamLeader_SectionAccess.qvd (qvd);

Here is my QVW import script:

SET NullInterpret=''; // <<< --- Only required if bringing information back from tables (not databases).

SECTION Access;

LOAD USERID,
     PASSWORD,
     NTNAME,
     ACCESS,
     GROUPSECURITYLINK
FROM [TeamLeader_SectionAccess.qvd] (qvd)
where 1=1;

This works fine if I either use just the USERID and PASSWORD fields and comment out NTNAME

This also works the other way around, when I remove the USERID and PASSWORD

The probem is when I leave them both in, I should be able to log straight in (as it's my NTNAME) although it still works when i type admin/admin

Can anyone help as I've been suffering since yesterday morning on this problem?

Thanks in advance

Richard

I've attached the files I'm working with.....

1 Solution

Accepted Solutions
fosuzuki
Valued Contributor II

Section Access using a QVD file with a combination of userID, password and NTName

Ok, got it. I think that you must use * in the USERID and PASSWORD fields for the lines that have a NTNAME.

TeamLeader_SectionAccess:
LOAD * Inline [
USERID, PASSWORD, NTNAME, ACCESS, GROUPSECURITYLINK
ADMIN, ADMIN, *, ADMIN,
*,*,CALLCENTRE\RICHARD.PEARCE,ADMIN,

];

Hope this helps you.

Regards,

Fernando

5 Replies
fosuzuki
Valued Contributor II

Section Access using a QVD file with a combination of userID, password and NTName

Hi Richard,

I tested it. First I just reloaded the qvw without changing it. After, closed QV and opened the QVW. I used admin/admin and it worked fine...

maybe I didn't understand your problem...?

Regards,

Fernando

Not applicable

Section Access using a QVD file with a combination of userID, password and NTName

Hi Fernando,

My mistake; the fault (for me) is that I shouldn't have to type in the Admin/admin as I'm CALLCENTRE\RICHARD.PEARCE if I follow what should be happenning I should be able to go straight into the file?

If I remove the fields USERID and PASSWORD it works and I can get straight in to the file.

Richard

fosuzuki
Valued Contributor II

Section Access using a QVD file with a combination of userID, password and NTName

Ok, got it. I think that you must use * in the USERID and PASSWORD fields for the lines that have a NTNAME.

TeamLeader_SectionAccess:
LOAD * Inline [
USERID, PASSWORD, NTNAME, ACCESS, GROUPSECURITYLINK
ADMIN, ADMIN, *, ADMIN,
*,*,CALLCENTRE\RICHARD.PEARCE,ADMIN,

];

Hope this helps you.

Regards,

Fernando

Not applicable

Section Access using a QVD file with a combination of userID, password and NTName

Great, this worked perfectly.... I thought over the last day I'd tried that combination in my testing but I guess not.

Thanks for taking the time to look at this for me.

Richard

Not applicable

Section Access using a QVD file with a combination of userID, password and NTName

Just checked my test files from yesterday when I used a excel workbook and also when doing an inline load no * was required......  frustrating .....

Thanks again