Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

raju_salmon
Contributor II

Section access question

Hi Experts,

In my project one of existing qlikview dashboards is showing Section Access table in table viewer. When I check the log file in file location, it does not have Section Access script. in dashboard I checked for hidden script. All options for hidden script are disabled. Can anyone please tell me how/where the section access details would be available?

Thanks in advance.

Hidden script options.png

Regards,

Raju

1 Solution

Accepted Solutions
anushree1
Valued Contributor

Re: Section access question

Did you check if if there is any include statement of a qvs file , there could be a possible situation that qvs file is included in the script which has the section access table.

If, not try loading part of the script using exit script and check where the section access table might get loaded.

My thought is that there could be an include statement with a qvs file loading the section access table 

8 Replies
Highlighted
Partner
Partner

Re: Section access question

is there a binary load in your script so a datamodel with section access is being loaded?

Regards

MVP & Luminary
MVP & Luminary

Re: Section access question

If you're seeing a table with the name Section Access then somebody probably didn't create the Access and Application sections correctly.
https://help.qlik.com/en-US/qlikview/April2019/Subsystems/Client/Content/QV_QlikView/Scripting/Scrip...

Here's an example of how it used:

 

Section Access;

Load * inline
[ACCESS,USERID,PASSWORD
ADMIN, A,X
USER,U,Y ];


Section Application;

Load some_stuff from some_source;

 


talk is cheap, supply exceeds demand
MVP
MVP

Re: Section access question

Somewhere you are doing wrong. Section access table doesn't appear in table viewer.

raju_salmon
Contributor II

Re: Section access question

Hi Martin,

There is no binary load in script.

Regards,

Raju

Partner
Partner

Re: Section access question

or maybe an include?

 

raju_salmon
Contributor II

Re: Section access question

Hi All,

Thanks for your response.
Section access script is not at all showing either while loading the script or in log file after completing the reload. But it is appearing in table viewer. If it is in hidden script, then Edit hidden script option should be enabled. If hidden script is not there then, Create hidden script option should be enabled. But if you observe in the image which I have attached, all options are disabled. How is it possible. Can anyone please tell me.

Thanks in advance.

Regards,

Raju
anushree1
Valued Contributor

Re: Section access question

Did you check if if there is any include statement of a qvs file , there could be a possible situation that qvs file is included in the script which has the section access table.

If, not try loading part of the script using exit script and check where the section access table might get loaded.

My thought is that there could be an include statement with a qvs file loading the section access table 

MVP & Luminary
MVP & Luminary

Re: Section access question

Checking for a prj-folder (which might contain invalid data) might be a further cause.

- Marcus