Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
Modernize Your QlikView Deployment webinar, Nov. 3rd. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Security Access

Hi Experts,

I am trying to apply data security to my document.

Please find my script below:

SECTION Access;

access:

load * Inline [

ACCESS, NTNAME

ADMIN, NA\HARI

USER, NA\HARI

];

SECTION Application;


When I am reloading the Qlikview Document, I do not face any issue.

But, when I am running through QMC, it's failing.


Please find the error below:


Error: Document open call failed. The document might require username and password.

Please help.

Thanks in advance.

Regards,

Nayana

1 Solution

Accepted Solutions
Highlighted
Not applicable

Hi All,

Thanks a lot for all the help.

I did not re-load and close the QV document. This was causing the error.

Rest all was fine.

Issue resolved now.

Regards,

Nayana

View solution in original post

10 Replies
Highlighted
Specialist III
Specialist III

Hey there,

Why do you have the same NTNAME for a User and for a Administrator? I might be wrong, but I think it isn't possible to do something like this. Also, do you have put a valid NTAME? Check that by using OSuser() function...

Regards,

MB

Highlighted
Not applicable

Hi Miguel,

Thanks for the reply.

I've removed the user line, but the script still fails.

And the NTNAME is as per QMC's username (as per Users-> user management tab).

If I apply OSUser(), the name shows NA in one line and HARI in another. Also no "\" is there.

I am confused.

Please help.

Regards

Highlighted
Creator III
Creator III

Hi,

Can you try like below.

Section Access;

STAR is *;

LOAD * INLINE

[

ACCESS, USERID, PASSWORD,

ADMIN, ADMIN,  ADMIN,

USER,A,A];

Section Application;

Thanks

Highlighted
Partner
Partner

Hi,

QMC will be running the reload as the service account entered during the set up, if this is not your user account you can have the above issue.

Check the user on the QlikView services and set them up as admin.

Mark

Highlighted
Partner
Partner

Hi ,

I presume that you are trying to reload this in QMC, so you need to add the user credential that are used for the QV Services.

HTH Andy

Highlighted
Not applicable

Hi Adrew,

Thanks for the reply.

I did not get you. Can you be please more precise ?

For QMC, I am not asked for credentials. I am asked credentials while logging in the server.

Should I provide that here ?

Thanks in advance.

Regards,

Nayana

Highlighted
Not applicable

Also, I just noticed that OSUser(), the name shows NA in one line and ARI in another and not HARI.

But QMC's username (as per Users-> user management tab) shows NA\HARI.


What to use in the code ?


Please help.


Thanks in advance.


Regards

Highlighted
Partner
Partner

OK you will have a user that run the QV services, their credentials need to be added to the SECTION ACCESS user list. E.g on my pc open the windows services applet (services.msc)

e.g on my PC it's qvservice

Highlighted
Not applicable

I added that now(in CAPS).

Still, it failed.

Please help.

Thanks in advance.


Regards