Qlik Community

Ask a Question

New to QlikView

If you’re new to QlikView, start with this Discussion Board and get up-to-speed quickly.

Announcements
Do More with Qlik - for Beginners and Beyond, Topic: Qlik Replicate on January 21, 2PM EST. REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor II
Contributor II

Select in field (trigger) does not work on server

Hi all,

I would like to set a default filter to one of my sheets, so I've set a trigger - OnActivateSheet and actions = Select in Field. The aim is to filter always the current month in [HistoryCreatedDateMonth]. I've set it as follows and it works fine offline (Qlikview Client), but when I distribute it to a server, it doesn't work at all:

1.PNG

Any idea how to make it work on server as well, please?

Many thanks!

1 Solution

Accepted Solutions
MVP
MVP

How you are navigating to sheet? If you are navigating via button then it won't work. You need to apply trigger to button as well. It only works when you click on tab to navigate

View solution in original post

3 Replies
MVP
MVP

How you are navigating to sheet? If you are navigating via button then it won't work. You need to apply trigger to button as well. It only works when you click on tab to navigate

View solution in original post

Contributor II
Contributor II

Via both:

  1. Text Object with 2 actions (activating the new sheet + select in field as above
  2. Triggers in sheet properties

Unfortunately, it doesn't work on a server. I've even tried to remove last document state in AP.

Contributor II
Contributor II

There was something wrong with the text object, since when I've created a new one, it works as @Kush you've mentioned. Thanks for you advice!