Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Statistic box too big, can't see number inside

As the title says, i have a statistic box wich sums some values and shows a big number

If the number is lower than 1 million i can fully see it, but otherwise i just see some #### instead

I have tried to make the statistic box wider, but there is no way to show that number

Any help would be really appreciated

Thanks

Tags (1)
4 Replies
danielrozental
Honored Contributor II

Statistic box too big, can't see number inside

Make sure you're formatting the number first in the number tab, you can also make the column wider just by hovering over the borders until the icon changes.

You can also just use a simple table to calculate all statistics you need.

Not applicable

Statistic box too big, can't see number inside

Hi Mmiorandi ,

If you don't want to change the number format try to make a right click on the chart & u'll have an option like

fit colomn width ... with that ur colmn width will be set automaticly

thanks

Meher

Not applicable

Re: Statistic box too big, can't see number inside

Can't find any of these hint working

- i could change the number format to not show the decimals, so it will be shorter and will fit the box, but i need to show them

- making the box wider with the mouse doesn't work: it always remains of the same dimension

- and i cannot even find this "fit column width" merwan mentioned =(

But i found a solution!

In the statistic box properties, general tab, i have to select the two chechboxes on the bottom left (something like "show standard error" and "cell borders"),so i can see the areas dedicated to the various elements, and adjust them manually

I don't understand exactly what that means, but it worked =)

Not applicable

Re: Statistic box too big, can't see number inside

Hey all, I know this is an old post but thought i would share my 2 cents.

I found (through lots of trial and error) that there are 2 ways to adjust a box size.

1)  You can adjust the size of the box by hovering the cursor over the side of the box until a white double sided arrow pops up.  If you have your settings on "size to data" this will allow you to adjust your box to the size of the data but no bigger or smaller.  This can be an issue if you are in a space crunch.  To get around this see option 2.

2) You can adjust the side of the "cell" which the data is in.  I say cell because i don't have a better name for it but it is essentially the size of the box that the data sits in.  You do this by hovering over your box edges until you see a black cross (the cross section is a double sided arrow).  If you cannot find the black cross, adjust your box size to its max (aka drag your box out until you cannot make it any bigger, then hover your cursor over the edge until the black cross pops up again) use this to adjust your data cells down to a reasonable size.  Then readjust your box size to fit your cell data

Hope this helps someone, somewhere

Community Browser