Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

mrjohn23
Contributor III

Store Command throwing general script error

I have created an app with a Store command. When I reload the script is works perfectly on the desktop but when I hand it off (to IT) to be loaded on the server this trips a general script error. Would anyone know how I can avoid this error?

Tags (2)
11 Replies
mwoolf
Honored Contributor II

Re: Store Command throwing general script error

You didn't give any details, so I'll guess.

Storing to a drive that isn't mapped on the server?

Employee
Employee

Re: Store Command throwing general script error

Maybe you storing to a folder that you don´t have access.

Re: Store Command throwing general script error

check the path of the Store command and check whether your qlikview service account has complete access for that folder or location

santiago_respane
Valued Contributor

Re: Store Command throwing general script error

Hi Mr Jhon,

please elaborate more (add some screen shots, sample app, etc) in order to help you with your issue.

When you say "hand it off" you mean publish and reload it via QMC? Fails on the first load?

Will be waiting for your comments.

Kind regards,

Partner
Partner

Re: Store Command throwing general script error

Share the Log to troubleshoot the issue

mrjohn23
Contributor III

Re: Store Command throwing general script error

Attached is the log file.

Re: Store Command throwing general script error

Check this time,

6/28/2016 11:36:33 AM

Showing some Access error with Uname and Pwd

- Anil

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
Partner
Partner

Re: Store Command throwing general script error

The error shows in log is not with store statement. It is some DB username and password issue. Please try to connect to DB and after select statement you write Exit script and check. If it works then Store command will also works.

MVP
MVP

Re: Store Command throwing general script error

Did you define the odbc data source (system data source) on the server and/or did you installed the driver for the db you're using? Also it seems (connect32) you're using a 32 bit connection.

6/28/2016 11:36:33 AM: 0008  ODBC CONNECT32*XUserId*XPassword*

6/28/2016 11:36:38 AM:       Error: SQL##f - SqlState: IM002, ErrorCode: 0, ErrorMsg: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

6/28/2016 11:36:41 AM:       General Script Error

6/28/2016 11:36:42 AM:       Execution Failed

6/28/2016 11:36:46 AM:      Execution finished.