Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Not applicable

Table non trouvée Concatenate "load * resident..."

Bonjour,

Je vous expose mon problème:

Je crée un cube de données qui comprend 4 projets différents contenant chacun 4 fichiers CSV.

Jusque là tout marche bien. Mais quand je veux créer une table "agrégat" qui est la concaténation des mes 4 autres tables (car une table par projets) je rencontre un problème lors de l'exécution.

Voila comment je construis ma table AGREGAT (sachant que je n'ai aucune erreur lors de la création des 4 autres tables):

J_AGREGAT:

load * resident J_AGREGAT_PHENIX;

Concatenate

loadresident J_AGREGAT_ORION;

Concatenate

loadresident J_AGREGAT_PYXIS;

Concatenate

loadresident J_AGREGAT_SIRIUS;

et voila l'erreur que j'ai lors de l'exécution du script:

Table non trouvée

Concatenate

    load *  resident J_AGREGAT_ORION

Ensuite la fenêtre d'exécution ne veut plus se fermer, je suis obligée de "tuer" le programme et de le redémarrer. Et quand je le redémarre, j'arrive quand même à avoir mes données dans la partie reporting. Car les fichiers QVD sont créés.

Quelqu'un a-t-il une idée d'où peut provenir le problème?

Je vous remercie

1 Solution

Accepted Solutions
Not applicable

Re: Table non trouvée Concatenate "load * resident..."

Bonjour,

si la table est non trouvée c'est qu'elle n'existe pas.

Je suppose que ce que tu charge dans J_AGREGAT_ORION est concatené dans la table precedante Phenix. ce qui explique pourquoi tu as tes données.

As-tu precisé noconcatenate load au chargement de tes 4 tables initiales ?

Regardes dans le log d'execution, cela peut aussi aider.

Gilles

6 Replies
Not applicable

Re: Table non trouvée Concatenate "load * resident..."

Bonjour,

si la table est non trouvée c'est qu'elle n'existe pas.

Je suppose que ce que tu charge dans J_AGREGAT_ORION est concatené dans la table precedante Phenix. ce qui explique pourquoi tu as tes données.

As-tu precisé noconcatenate load au chargement de tes 4 tables initiales ?

Regardes dans le log d'execution, cela peut aussi aider.

Gilles

Not applicable

Table non trouvée Concatenate "load * resident..."

En effet, le noconcatenate résout le problème de la table non trouvée. Je le précisais ailleurs (devant les tables sur lesquelles reposaient les J_AGREGAT).

Je te remercie Gilles. J'aurai cherché encore pendant un bout de temps ...

Par contre à la fin de l'exécution, la fenêtre d'exécution ne disparait pas (ça reste quand même pendant plusieurs minutes). je dois forcer sa fermeture en cliquant sur abandonner et tuer le programme et ensuite relancer QlikView...;

Not applicable

Re: Table non trouvée Concatenate "load * resident..."

pour la fin d'execution, regarde le log d'execution s'il y a des infos. Regarde aussi ton modele de données. Il y a peut-etre les liaisons entre tables qui font que QV mouline et ne rend pas la main.

Fais-tu un drop de tes 4 tables initiales en fin de script (je suppose qu'elles ne sont plus utiles)?

Gilles

Not applicable

Table non trouvée Concatenate "load * resident..."

Oui je drop toutes les tables dont je n'ai plus besoin ( il y en a plus que les 4 la dont on parle).

et la, ça prend beaucoup moins de temps, mais bon disons 1 minute environ ( ce qui est mieux qu'avant) et ça se ferme donc tout seul plus  besoin de le forcer à fermer.

Qu'est ce que tu entends par le log d'exécution? s'agit-il du journal (.log) créé lors de l'exécution?

Not applicable

Re: Table non trouvée Concatenate "load * resident..."

oui, j'entends le log créé lors de l'execution du rechargement.

Not applicable

Table non trouvée Concatenate "load * resident..."

Je te remercie Gilles.

Tout ça m'a beaucoup aidé à résoudre mon problème

Bonne journée