Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Not applicable

Trigger not working when Web View is On

I have a calendar slider applied to a set of graphs (x-axis = day) that are set to be visible when Toggleview = 1.   I have another set of graphs (x-axis = month) that are set to be visible when Toggleview = 2 (no calendar slider).  When the calendar slider is moved to a given time period, the daily graphs change as expected.  When the user selects Toggleview=2, I want to “Clear All” so the next set of graphs do not keep the previous selection and show the entire year.

So I created a Variable Event Trigger on Toggleview, where “On Change” the action is “Clear All”.  This works fine when “Turn on/off web view” is “Off”.   However when I turn web view to “On”, this behavior no longer works.   The graphs for Toggleview=2 have not “cleared” and the selection from the slider is still active.

Is this a problem?  Am I missing something?  Why would the behavior be different with the web view On or Off?

Thanks for any suggestions you might have.

5 Replies
Not applicable

Re: Trigger not working when Web View is On


Hi dbmagnus,

I am also facing similar type of problem.Did you found solution for this problem,if so please share with me . It will be a huge help to me.

Thanks

Murali krishna

jerrysvensson
Valued Contributor II

Re: Trigger not working when Web View is On

When using Developer and WebView macros doesn't work.  See Reference manual.

Not applicable

Re: Trigger not working when Web View is On

Hi Jerry,

Thanks for the reply

Here I am not using any macro . I have two calenders for from and to dates . Once i select the dates in the calender and click on button , I wrote an action to apply the dates to my date field in the application.It is working perfectly in desktop mode and not in the webview.

Thanks

Murali krishna

jerrysvensson
Valued Contributor II

Re: Trigger not working when Web View is On

Do any actions work in WebView?

mdmukramali
Valued Contributor II

Re: Trigger not working when Web View is On

HI

Not all triggers works.

Refer Reference Manuel for more information

Regards

Community Browser