Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Visual cues not working

Hi all,

Hope you can help.


Within a straight table, we can change the backgroud of a cell based on 'Visual cues',  great for highlighting ares of interest in a table. However, in each cell I don't just have a number (say field1) I also have a freq

=avg(field1)
=avg(field1) & '(' & count(field1) & ')'


From the above two expressions, I am able to use visual cues for the first but not the second.

Is there any way around this as I really want to include the freq within each cell.

Regards,

Revlin

1 Solution

Accepted Solutions
MVP
MVP

Re: Visual cues not working

Visual cues only work with expression that return numericals. Your second expression is returning a string.

But you can use a background color attribute expression (click on the small plus sign next to your expression in expression tab) and enter as defiition something like

=if(avg(field1) < 0, lightred() )

i.e. you must create an expression that returns a color (can also be created using rgb() or argb() functions).

Hope this helps,

Stefan

2 Replies
MVP
MVP

Re: Visual cues not working

Visual cues only work with expression that return numericals. Your second expression is returning a string.

But you can use a background color attribute expression (click on the small plus sign next to your expression in expression tab) and enter as defiition something like

=if(avg(field1) < 0, lightred() )

i.e. you must create an expression that returns a color (can also be created using rgb() or argb() functions).

Hope this helps,

Stefan

Not applicable

Re: Visual cues not working

Thank you Stefan - this is exactlky what I was looking for.

Regards

Revlin

Community Browser