Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Surendrap595
New Contributor

error while loading data in Qliksense

Dear Experts,

I am new to the Qliksense and am getting the error while loading data from MYSQL DB to Qliksense app.

clipboard_image_0.png

after getting this error i have checked there is no Syntax error in Script but after clicking on Load data its throwing this error and also i have deleted the table from Qlik sense app but still its throwing the same error with same table name after deleting table aslo.

Could you please help me on this issue.

 

Thank you in advance.

Best regards 

Surendra

6 Replies
Partner
Partner

Re: error while loading data in Qliksense

can you share the part of script where this error is occuring.
I would also copy the sql and run on the mysql client to diagnose
Surendrap595
New Contributor

Re: error while loading data in Qliksense

Hi ,

The script what i am using is as follows.

LIB Connect to 'SG_DATASOURCE'

Load 'ID',
'Total_sales',
'Total_quantity'
'Units'
SQL SELECT ID,
'TOTAL_SALES',
'TOTAL_QUANTITY',
'Units'
FROM SGDB.'SALESORDERS';

while clicking on load data am getting the error:

SQLSTATE:3700,Error code: 1064,ErrorMsg:[MYSQL][ODBC5.3(A) dRIVER][mysql-5.7.19-log]

Here i am loading the table from MYSQL DB to Qliksense.

Colud please check and help me on this issue.

Partner
Partner

Re: error while loading data in Qliksense

Load 'ID',
'Total_sales',
'Total_quantity'
'Units';
SQL SELECT ID,
'TOTAL_SALES',
'TOTAL_QUANTITY',
'Units'
FROM SGDB.'SALESORDERS';

I can see missing semi-colon before SQL Select.
Try to add it. Or just re-select the data from that table in Edit Script .
I think, it might fix the issue
Regards,
Sergey
Surendrap595
New Contributor

Re: error while loading data in Qliksense

Hi Seregy,

its there in the script but its not working ,its throwing same error.

is there any issue with single quotes i found some posts like we need to use

SET DirectIdentifierQuoteChar='``';

LIB Connect to `SG_DATASOURCE`

Load `ID`,
`Total_sales`,
`Total_quantity`
`Units`;
SQL SELECT ID,
`TOTAL_SALES`,
`TOTAL_QUANTITY`,
`Units`
FROM SGDB.'SALESORDERS';

is the above script is correct or is there any mistakes.

Thank you.

Surendra

Partner
Partner

Re: error while loading data in Qliksense

Is it because of missing ';' at here?

>>>LIB Connect to `SG_DATASOURCE`

Partner
Partner

Re: error while loading data in Qliksense

I'd recommend you to comment that script and select data from the table again.

When you copy script from web-sites, quotes might be changed. You need to replace them with a normal ones, which you can type on your keyboard.

Although, it won't be an issue if you select data from SQL table again. It will also add all necessary semi colons.

Regards,
Sergey