Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

felcar2013
Contributor III

field not found when loading from qvd

hi,

i created a qvd from a table "customer", but when i reload it, it always says "field not found <contact_id>". I do not know if i am doing something wrong, any comment would be very appreciated.

this is the table i call from the qvd

customer_x:

and this is the original qvw document

customer:

LOAD contact_id,

    contact_acrm_dim_abc_segment,

     contact_programcountry,   

    contact_dim_month;

SQL SELECT *

FROM DB_Name;

STORE customer into customer.qvd;

DROP Table customer;

1 Solution

Accepted Solutions
MVP
MVP

Re: field not found when loading from qvd

this is the table i call from the qvd

customer_x:

and this is the original qvw document

I think your post misses some details (about the qvd load statement here). Please post your complete code snippet (how you load from qvd).

Have you tried

LOAD * FROM customer.qvd (qvd);

and checked the field names?

4 Replies
MVP
MVP

Re: field not found when loading from qvd

this is the table i call from the qvd

customer_x:

and this is the original qvw document

I think your post misses some details (about the qvd load statement here). Please post your complete code snippet (how you load from qvd).

Have you tried

LOAD * FROM customer.qvd (qvd);

and checked the field names?

felcar2013
Contributor III

Re: field not found when loading from qvd

hi thanks for your help

sorry, yes, i forgot the load. it was like this originally: (now it works, i added the ".... (qvd) " at the end of the load statement and it worked.

customer:

LOAD contact_id,
   
contact_abc_segment,
    contact_programcountry",   
   
contact_dim_month";
SQL SELECT *
FROM db_CV.dbo."tmp_20130208_Kundenwanderung_1;

STORE kunden into kunden.qvd;

DROP table customer;

customer_x:
LOAD contact_id,
    contact_programcountry as programcountry1,   
    c
ontact_dim_month as month1
from kunden.qvd;

MVP & Luminary
MVP & Luminary

Re: field not found when loading from qvd

You create a table named customers, not kunden. So the line STORE kunden into kunden qvd doesn't store anything. And that's why if you load something from kunden.qvd you get an error. kunden.qvd is empty. Simply rename customers to kunden or store customers into kunden.qvd.


talk is cheap, supply exceeds demand
felcar2013
Contributor III

Re: field not found when loading from qvd

thanks, yes this is only an spelling error, i just changed the names for the posting and forgot them.

Now it is working, i added the qvd in parenthesis at the end

thanks