Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

aboumejjane
Contributor

google maps appears but no link with lat & lng

Hi Guys,

I'm having some problems with Google Maps in Qlikview. I've added google maps in Qlikview and loaded some lat and long data.

I can see the World Map, when it should be the map of the Netherlands.

The latitude and longtitude numbers seem to be correct.

I've attached my qlikview document. Can some please explain want i'm doing wrong?

Thanks in advance!

Isam

1 Solution

Accepted Solutions
Not applicable

Re: google maps appears but no link with lat & lng

Hi Isam

Divide long/lat by 100000000

I create a mini app with the cities coordinates. it works

JJ

11 Replies
aboumejjane
Contributor

google maps appears but no link with lat & lng

latlong.png

Loading lat & long with the above numbers don't work.

I've check it my other qlikview file. It seems that when I load the lat. & long. based on the format below it works.

Untitled.png

I want to change my format to this format above (hoping that it will solve the problem). I just don't know how to do this.

Isam

Not applicable

google maps appears but no link with lat & lng

latitude/1000000

longitude/10000000

aboumejjane
Contributor

Re: google maps appears but no link with lat & lng

Thanks your help ! But that didn’t work L.

Not applicable

google maps appears but no link with lat & lng

Might have something to do with your thousands separator and decimal separator.

Try changing this:

SET ThousandSep='.';

SET DecimalSep=',';

to this:

SET ThousandSep=',';

SET DecimalSep='.';

Highlighted
aboumejjane
Contributor

Re: google maps appears but no link with lat & lng

Hi,

I already tried that . That didn't work

Regards,

Isam

Not applicable

Re: google maps appears but no link with lat & lng

Hi Isam

Divide long/lat by 100000000

I create a mini app with the cities coordinates. it works

JJ

aboumejjane
Contributor

Re: google maps appears but no link with lat & lng

Hi JJ,

Sorry for the late response!! Thank so much for you help!! It worked!!!

just one question why did you divide the long/lat by 100000000?

Thanks !

Isam

Not applicable

Re: google maps appears but no link with lat & lng

Hi, because long/last must be between -90 & +90

JJ

aboumejjane
Contributor

Re: google maps appears but no link with lat & lng

Hi JJ,

Is it possible to have like a small navigation within google maps where you can navigate trough the map? Or like a 'hand' were you can drag the map to the left,right, up or down to see a certain location?

Thanks in advance!

Regards,

iSam

Community Browser