Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

gerhardl
Contributor II

load problem

Hi,

I'm loading a daily account extract into QV. Now I am adding transaction extracts to it.

I load the account extract first, then I load the transaction extracts. I concatenate all the transaction extracts.

All of the extracts have a field called [Account No] which is my key field. However, when I now create a statistic box for [Account No], all the values show as n/a.

I want to see the total number of Accounts, and when I select something I want to see how many accounts are selected, and their transaction details.

I am obviously loading this wrong, could someone please help out?

Regards,

G

Tags (2)
1 Solution

Accepted Solutions
MVP
MVP

load problem

It's hard to guess what wen wrong, but I suspect that the problem is related to the fact that now Account ID become a key field. You can't simply count Key Fields, because the results can't be unique... You should decide what table (Transactions or Master table) do you want to use for your statistics, and load Account ID twice in that table, renaming the field into something else. The second field is not going to be a key, and therefore you can get statistics on it.

1 Reply
MVP
MVP

load problem

It's hard to guess what wen wrong, but I suspect that the problem is related to the fact that now Account ID become a key field. You can't simply count Key Fields, because the results can't be unique... You should decide what table (Transactions or Master table) do you want to use for your statistics, and load Account ID twice in that table, renaming the field into something else. The second field is not going to be a key, and therefore you can get statistics on it.

Community Browser