Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

ananyaghosh
Contributor III

must include is not working at qliksense

hi,

I have one folder connection in qliksense system:- 'EDI Vision Service Console' and I have created a 'Data Extractor' folder in that folder.

but when I include one script it gives me error of file not found:

$(Must_Include= lib://EDI Vision Service Console\Data Extractor\SUMMARISER_TRANSACTIONAL_FULL_LOAD.qvs);

Please help me.

What should I consider in the must include?

Message was edited by: sandip Ghosh

Tags (1)
1 Solution

Accepted Solutions
Highlighted
ananyaghosh
Contributor III

Re: must include is not working at qliksense

Here's what finally worked.

$(Include=[lib://FolderConnection\Subfolder under FolderConnection\Scripts\code.qvs]);

8 Replies

Re: must include is not working at qliksense

Can you share the error image using Include

$(Include= lib://EDI Vision Service Console\Data Extractor\SUMMARISER_TRANSACTIONAL_FULL_LOAD.qvs);

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
HirisH_V7
Honored Contributor

Re: must include is not working at qliksense

Hi,

If we you must_include means, it will throw an error if the file is not found.

In case you don't want to see any error means(may be no file is fetching by include), you can use Include in place of must_include.

-Hirish

HirisH
“Aspire to Inspire before we Expire!”
ananyaghosh
Contributor III

Re: must include is not working at qliksense

hi,

I am using the below code:-

$(Must_Include= [lib://EDI Vision Service Console/Data Extractor\SUMMARISER_TRANSACTIONAL_FULL_LOAD.qvs]);

and it says that script not found. What to do now?

HirisH_V7
Honored Contributor

Re: must include is not working at qliksense

Do check are u pointing the required Script file.

HirisH
“Aspire to Inspire before we Expire!”
Highlighted
ananyaghosh
Contributor III

Re: must include is not working at qliksense

Here's what finally worked.

$(Include=[lib://FolderConnection\Subfolder under FolderConnection\Scripts\code.qvs]);

HirisH_V7
Honored Contributor

Re: must include is not working at qliksense

oh good buddy. Please close thread.

HirisH
“Aspire to Inspire before we Expire!”
trdandamudi
Honored Contributor II

Re: must include is not working at qliksense

Just want to clarify here:

"Include" and "Must_Include" work exactly the same. The difference is, if the script file is missing in the path location then "Include" will not throw an error but "Must_Include" will give you an error.

So when you said "Finally it worked " the meaning is either the file is available in the path provided or it is not.

Hope this helps...

Re: must include is not working at qliksense

Try like this?

SET Var = '$(Must_Include= [lib://EDI Vision Service Console/Data Extractor\SUMMARISER_TRANSACTIONAL_FULL_LOAD.qvs])';

Trace $(Var);


And show me the Reload script wizard elapsed time scrrenshot?

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)