Qlik Community

Ask a Question

New to QlikView

If you’re new to QlikView, start with this Discussion Board and get up-to-speed quickly.

Announcements
Qlik Highlights 2020 Giveaway! Watch, reply and have a chance to win a $200 Amazon Gift Card! Watch Video
cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor II
Contributor II

"-" Hyphen in Graph

Dear Qlik Viewers,

Greetings!

I am getting hyphen in my graph as you can see in the last right hand.

I am unable to rectify this issue, please assist.

Below is the table view of the 3 files which I am using for qlik view document but it has created 01 Syn Key.

graph1.JPG

table view.JPG

 

Appreciate your assistance.

Thank you.

4 Replies
Partner
Partner

Hi
It seems like you have some null values in dates thats the reason for the '-'
Contributor II
Contributor II

I have checked the data once again, but in my data all the dates have values and nothing as null.

 

 

Master II
Master II

Hi Ebahadur,'

First try to remove synthetic keys like this:

ActiveCrew:

Load

STAFFNO &'|'&CRank as %Key,

STAFFNO as Active_STAFFNO ,

CRank as Active_CRank ,

....rest of the fields;

K_Indicator:

Load

STAFFNO &'|'&CRank as %Key,

STAFFNO as Indicator_STAFFNO ,

CRank as Indicator_CRank ,

....rest of the fields;

 

Assemsment:

Load

STAFFNO &'|'&CRank as %Key,

STAFFNO as Assesment_STAFFNO ,

CRank as Assesment,

....rest of the fields;

Else if you want to use a single Field in UI then you have to compliment Link tables.

You can find the link table logic here:

https://www.learnallbi.com/link-table-in-qlikview/ 

Best Regards,
KC
Master II
Master II

You can also comment STAFFNO  and CRank  from two tables if you know which table is the master table which have all possible entries.

Best Regards,
KC