Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
QlikWorld 2020: Join us May 11 - 14, 2020 in Phoenix, AZ. Register early and save $400. Learn More
dudumoscona
New Contributor

subtraction between to fields not showing results

Hi ,

I have the following script , the subtraction in the end giving no results , i've added a picture of no result

What am i doing wrong?

INVENTORYCDP1:

LOAD PARTNAME AS [PartIDPriorityCDP] ,
PARTDES AS [PartNamePriorityCDP],
COST AS [COSTPriorityCDP],
WARHSNAME AS [WARHSNAMEPriorityCDP],
INVENTORYLEVEL AS [INVENTORYLEVELPriorityCDP],
UNIT AS [UNITPriorityCDP],
TOTALCOST AS [TOTALCOSTPriorityCDP]
FROM
[..\..\1_resources\1_Raw\INVENTORYCDP.QVD]
(
qvd);

LEFT JOIN

LOAD PARTID AS [PartIDPriorityCDP],
LOCATIONID AS [WARHSNAMEPriorityCDP],
Num(ONHAND, '0') as ONHAND ,
RepairCenterName

FROM
[..\..\1_resources\1_Raw\INVENTORYLEVELCMMS.QVD]
(
qvd);

STORE INVENTORYCDP1 INTO [..\..\1_resources\1_Raw\INVENTORYCDP1.QVD];
DROP Tables INVENTORYCDP1;

Directory;
LOAD PartIDPriorityCDP AS [PartIDPriorityCDP1] ,
WARHSNAMEPriorityCDP AS [WARHSNAMEPriorityCDP1],
PartNamePriorityCDP AS [PartNamePriorityCDP1],
COSTPriorityCDP AS [COSTPriorityCDP1],
INVENTORYLEVELPriorityCDP AS [INVENTORYLEVELPriorityCDP1] ,
UNITPriorityCDP AS [UNITPriorityCDP1],
TOTALCOSTPriorityCDP AS [TOTALCOSTPriorityCDP1] ,
ONHAND AS [ONHAND CMMS],
RepairCenterName AS [RepairCenterName1],



(INVENTORYLEVELPriorityCDP
- ONHAND) as [DIFF BETWEEN SYSTEMS]

FROM
[..\..\1_resources\1_Raw\INVENTORYCDP1.QVD]
(
qvd);

1 Solution

Accepted Solutions
jerifortune
Contributor III

Re: subtraction between to fields not showing results

Have you tried to convert the two fields to numeric values before performing the subtraction?

View solution in original post

4 Replies
jerifortune
Contributor III

Re: subtraction between to fields not showing results

Have you tried to convert the two fields to numeric values before performing the subtraction?

View solution in original post

Re: subtraction between to fields not showing results

May be scroll to the right and see, If values are coming as Zero?

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
dudumoscona
New Contributor

Re: subtraction between to fields not showing results

Hi ,

Tried to put

Num(Field) and tried Num#(Field) - none worked.

dudumoscona
New Contributor

Re: subtraction between to fields not showing results

Nothing comes.