Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
Read about Qlik’s Response to COVID-19 Read the Letter, Join the Group.
New Contributor III

table not found error; the table is there and loads data rows ...

Below is the end of my load script with error Error: Table 'EmployeeCostCenterDG111' not found.

I have tried everything I know to do, the 111 in the table name is just for troubleshooting.

Has anybody got a work around or a fix? I used Find in the script editor to verify the table names are exactly the same.

2018-09-21 15:21:14 2706 EmployeeCostCenterDG111:

2018-09-21 15:21:14 2707 LOAD

2018-09-21 15:21:14 2708  AutoNumber(OfficerNbr & '-' & [Assignment Start Date], 'EmployeeCenterKey') as EmployeeCenterKey,

2018-09-21 15:21:14 2709  *

2018-09-21 15:21:14 2710

2018-09-21 15:21:14 2711 LOAD

2018-09-21 15:21:14 2712  OfficerNbr,

2018-09-21 15:21:14 2713  EffectiveDate as [Assignment Start Date],

2018-09-21 15:21:14 2714

2018-09-21 15:21:14 2715                         

2018-09-21 15:21:14 2716  if( OfficerNbr = peek('OfficerNbr'),date(peek('Assignment Start Date')-1), if(not isnull(EmployeeEndDate), Today(), AddMonths(Today(),15))) as [Assignment End Date],

2018-09-21 15:21:14 2717  [Cost Center]

2018-09-21 15:21:14 2718 RESIDENT Temp_EmployeeCostCenter

2018-09-21 15:21:14 2719 Where isnull(EmployeeEndDate) or (not isnull(EmployeeEndDate) and  (EffectiveDate < EmployeeEndDate))

2018-09-21 15:21:14 2720 Order By OfficerNbr, EffectiveDate DESC

2018-09-21 15:21:14       5 fields found: EmployeeCenterKey, OfficerNbr, Assignment Start Date, Assignment End Date, Cost Center,

2018-09-21 15:21:14      2,884 lines fetched

2018-09-21 15:21:14 2745 Temp_DGdate_Match:

2018-09-21 15:21:14 2746 IntervalMatch ([DGdate],OfficerNbr) LOAD

2018-09-21 15:21:14 2747  [Assignment Start Date],

2018-09-21 15:21:14 2748  [Assignment End Date],

2018-09-21 15:21:14 2749  OfficerNbr

2018-09-21 15:21:14 2750 RESIDENT EmployeeCostCenterDG111

2018-09-21 15:21:14      Error: Table 'EmployeeCostCenterDG111' not found

2018-09-21 15:21:54      Execution Failed

2018-09-21 15:21:54      Execution finished.

1 Solution

Accepted Solutions
Highlighted
Honored Contributor II

Re: table not found error; the table is there and loads data rows ...

As we do not see the entire script, My guess is you are concatenating  "EmployeeCostCenterDG111" into the prior table. Once it is concatenated into the prior table that table is not available and that is the reason you are getting that error. I think you need "NoConcatenate" like below:

Noconcatenate

EmployeeCostCenterDG111:

...

...

...

View solution in original post

2 Replies
Highlighted
Honored Contributor II

Re: table not found error; the table is there and loads data rows ...

As we do not see the entire script, My guess is you are concatenating  "EmployeeCostCenterDG111" into the prior table. Once it is concatenated into the prior table that table is not available and that is the reason you are getting that error. I think you need "NoConcatenate" like below:

Noconcatenate

EmployeeCostCenterDG111:

...

...

...

View solution in original post

Highlighted
Esteemed Contributor III

Re: table not found error; the table is there and loads data rows ...

Can you share the script you are trying to run? Are you using any joins in your tables where DG111 is getting joined?