Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

aboumejjane
Not applicable

wrong results on gauge chart

Hi Guys,

I have a gauge chart that calculates the performance of shipments ontime. This is the expression that I use:

Count({<Status={OnTime}>} Destination) / Count (Destination)

snapshot.JPG

The results are oke as long as I don't select the late shipments in the one of the selection fields.

When I select shipments that are Late, the performance meter goes 100% (ontime), which normaly should be the complete opposite.

Is my expression set right? or do I need to add something else to my expression? or is the problem somewere else.

How can I add the actual number as a text in the middle of the gauge chart? I only found how to add text above the gauge.

Hope u can help me out!!

Thanks in advance

iSam

9 Replies
its_anandrjs
Not applicable

wrong results on gauge chart

Hi,

For first when you select any other field the data would be change in gauge beacuse there is a relation ship that is the reason, for this i suggest use {1} with this code

Count({1} {<Status={OnTime}>} Destination) / Count (Destination)

and for adding a tex go to Presentation -> Text in Chart -> Add Text give the expression in text box.

Regards

Anand

aboumejjane
Not applicable

Re: wrong results on gauge chart

Hi Thanks for your help!

I’ve added the , however the gauge still goes to 100%. Btw, where does the (function) stand for?

Thanks!!!!

isam

its_anandrjs
Not applicable

Re: wrong results on gauge chart

Hi,

Try to put only { }  in place of { 1 } or you have any sample if so please provide to me.

Regards

Anand

SunilChauhan
Not applicable

wrong results on gauge chart

if you have dimension then remove dimension

dimension is not required is guage chart

SunilChauhan
Not applicable

wrong results on gauge chart

or you can

use below code

Count({<Status={"OnTime"}>} Destination) / Count (Destination)

aboumejjane
Not applicable

Re: wrong results on gauge chart

Hi,

That doesn’t work. I get wrong expression. I think there something wrong with the calculation.

Have a look at the screenshot:

When I select shipments ‘late’, I get a “ontime” result of 1097% Smiley Frustrated. Which in my case indicates that the expression is calculating something wrong.

Hope u can help

its_anandrjs
Not applicable

Re: wrong results on gauge chart

Hi,

I think you need to check your segments setting also what you define there please check once, also if you have any small sample file so i can understand that.

Regards,

Anand

gandalfgray
Not applicable

wrong results on gauge chart

Hi aboumejjane

Is Destination really a unique identifier for the Shipments?

If not, I recommend you to replace Destination with Distinct Shipment_ID in your expression (assuming Shipment_ID is a unique id in Shipment)

/gg

aboumejjane
Not applicable

Re: wrong results on gauge chart

Hi There,

Sorry for my late response. I needed to make a small modification before I could send you the application.

I’m also struggling with adding text to the gauge chart. If added text but I can’t get it below the meter.

Hope you can help.

Cheers

iSam