Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Announcements
Save the Date: QlikWorld Online, June 24-25, 2020. Free global virtual event for data integration and data analytic gurus. Register Today
Highlighted
Contributor III

y axes not showing in percent (using Dual)

How can I have y axes showing as percent

If I try to change format setting from the Number tab the dual function will not work anymore,

so guess need a solution within the Dual function,

=Dual(

If(MyDate=Max(total MyDate), Name, ''),

Sum ([Grade])/Max(Total Aggr(Sum([Grade]), [Name]))

)

Thanks

Raphael06-11-2017 10-18-19.png

1 Solution

Accepted Solutions
Highlighted

Re: y axes not showing in percent (using Dual)

Is this what you are after?

Capture.PNG

View solution in original post

11 Replies
Highlighted
Valued Contributor

Re: y axes not showing in percent (using Dual)

Hi

PFA the desired app.

Regards
Pratyush

Highlighted
Contributor III

Re: y axes not showing in percent (using Dual)

No good

As I said:"If I try to change format setting from the Number tab the dual function will not work anymore,"

so in your solution we do not have the legend on the line of the Graph! but thanks for trying06-11-2017 11-12-39.png

Highlighted

Re: y axes not showing in percent (using Dual)

Are you going to have this?

Capture.PNG

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
Highlighted
Contributor III

Re: y axes not showing in percent (using Dual)

no here too the legend is not on the line, have a look on the right (the names)

Highlighted
MVP
MVP

Re: y axes not showing in percent (using Dual)

Would putting % on the data points be an option? Like:

Capture.JPG

Highlighted
Contributor III

Re: y axes not showing in percent (using Dual)

I have many observations , so do not want to show the percents on the line, but rather just the Legend at the end and the y axes as Percent

Highlighted

Re: y axes not showing in percent (using Dual)

Is this what you are after?

Capture.PNG

View solution in original post

Highlighted
Contributor III

Re: y axes not showing in percent (using Dual)

yes, still trying to understand how you did

Highlighted

Re: y axes not showing in percent (using Dual)

Created a second expression for putting the name

Capture.PNG

If you see for display option, Line is unchecked and only Values on Data Points is checked. This expression shows the name, while the first expression handles the axis and the line