Skip to main content

Official Support Articles

Search or browse our knowledge base to find answers to your questions ranging from account questions to troubleshooting error messages. The content is curated and updated by our global Support team

NEW webinar Dec. 7th: 2023 Outlook, A Pivotal Year for Data Integration SIGN ME UP!

Qlik NPrinting: Days to Keep / Reports to Keep Setting Ignored

Showing results for 
Search instead for 
Did you mean: 

Qlik NPrinting: Days to Keep / Reports to Keep Setting Ignored

While running Qlik NPrinting Tasks, many reports are generated. However, the setting for Days to Keep / Reports to Keep seems to be ignored.



Qlik NPrinting all versions


The first thing to consider is that Qlik NPrinting generates one report for each Newsstand user. For this reason, there will be one file for each user, and not "just one", in the Qlik NPrinting Application Data folder. Those reports may be absolutely identical. 

In that sense, the "report to keep" setting does not apply here, and should be considered as "report to keep per user". There is currently an improvement at R&D. Check improvement on days to keep in Nprinting for details. In addition, see Publish task "Reports to Keep" does not work during first 24 hours.

As for the setting apparently being ignored, by default runs the check to delete old reports once every 24 hours. If no new report has been run in the meantime, the old reports will not be deleted, even if more than one day has passed.

Should there be a feeling that the periodic check is not run, the settings can be enforced:

  1. Stop the Qlik NPrinting services Proper Order to Restart Qlik NPrinting Services
  2. Navigate to and open  C:\Program Files\NPrintingServer\NPrinting\Scheduler\scheduler.config
  3. Add the below lines before the </appSettings> closing tag
    <add key="cleanup-period" value="1800" />
    <add key="cleanup-period-files" value="43200" />​
  4. Restart the services


The first setting is the recurrence in seconds (default: 30 minutes) for the task that will check for reports in the newsstand and unlink the older ones.
The second setting is the recurrence in seconds (default: 24 hours) for the task that will scan and remove the actual files, after checking that the conditions about days and reports to keep, plus the presence of newer reports that supersede them, are met. In this case, we would change the default value to a shorter time (43200 seconds, 12 hours) to make sure the task is run more frequently.

Labels (1)

Hi ,

i am trying to implement the same.

however during the changes to config file 

it promts me to save in a different format.

can you assist me on this . 

as the service scheduler is down. thanks 


Digital Support
Digital Support

Hello @apacbi_smbc 

This may indicate that you do not have the correct permissions to overwrite the existing .config file (either because it is still in use by a service that was not shut down, or because you do not have the correct file permissions).

Verify that the service is shut down and verify your file permissions on disk (you need read/write permissions). If both are correct and you still cannot save it as a .config file, then you can try this workflow:

  1. copy the existing file (name it .config.old or anything that would indicate it is an old version of the file). This is your backup. 
  2. edit the remaining scheduler.config file
  3. save it and add, for example, .txt as an extension when you are prompted to do so. Your file will then be called scheduler.config.txt.
  4. go back to the location of the file, and move/remove the original scheduler.config
  5. then rename your new scheduler.config.txt file to scheduler.config by removing the .txt.

This is a bit of a roundabout way of going about it, but it will work.

All the best,


Version history
Last update:
‎2021-10-22 05:53 AM
Updated by: