Skip to main content
Announcements
July 15, NEW Customer Portal: Initial launch will improve how you submit Support Cases. READ MORE

Release Notes Qlik Sense PostgreSQL installer version 1.2.0 to 1.4.0

No ratings
cancel
Showing results for 
Search instead for 
Did you mean: 
Sebastian_Linser

Release Notes Qlik Sense PostgreSQL installer version 1.2.0 to 1.4.0

Last Update:

Dec 20, 2023 8:42:07 AM

Updated By:

Sonja_Bauernfeind

Created date:

May 31, 2023 5:36:32 AM

The following release notes cover the Qlik PostgreSQL installer (QPI) version 1.2.0 to 1.4.0.

Content

 

What's New

Silent install/upgrade is supported beginning with Qlik PostgreSQL Installer 1.4.0 and later. QPI can now be used with silent commands to install or upgrade the PostgreSQL database. (SHEND-973)

 

1.4.0 December 2023 Release Notes

Improvement / Defect Details
   
SHEND-1359, QB-15164: Add support for encoding special characters for Postgres password in QPI If super user password is set to have certain special characters, QPI did not allow upgrading PostgreSQL using this password. The workaround was to set a different password, use QPI to upgrade the PostgreSQL database and then reset the password after the upgrade. This workaround is not required anymore with 1.4.0 QPI, as 1.4.0 supports encoded passwords.
   
SHEND-1408: Qlik Sense services were not started again by QPI after the upgrade QPI failed to restart Qlik services after upgrading the PostgreSQL database. This has been fixed now.
   
SHEND-1511: Upgrade not working from 9.6 database In QPI 1.3.0, upgrade from PostgreSQL 9.6 version to 14.8 was failing. This issue is fixed in QPI 1.4.0 version.
   
QB-21082: Upgrade from May 23 Patch 3 to August 23 RC3 fails when QPI is used before attempting upgrade.

QB-20581: May 2023 installer breaks QRS if QPI was used with a patch before. 
Using QPI on a patched Qlik Sense version caused issues in the earlier version. This is now supported.

 

 

Known Limitations (1.4.0)

  • Rollback is not supported.
  • Database size is not checked against free disk space before a backup is taken.
  • QPI can only upgrade bundled PostgreSQL database listening on the default port 4432. Using QPI to upgrade a standalone database or a database previously unbundled with QPI is not supported.
  • Cannot migrate a 14.8 embedded DB to standalone
  • Windows Server 2012R2 does not support PostgreSQL 14.8. QPI cannot be used on Windows Server 2012R2.

 

1.3.0 May 2023 Release Notes

Improvement / Defect Details
   
SHEND-1261: Allow upgrade from the bundled postgres version 12.5 to 14.8 version using QPI You can now update the embedded Qlik Sense Repository Database from versions 9.6 and 12.5 to version 14.8. (This is due to the following security issues of PostgreSQL)
   
SHEND-971: Allow custom Qlik Sense Installation Folder for use with QPI When Qlik Sense is installed outside of the standardfolder C:\Program Files\Qlik\Sense e.g. (D:\Qlik\Sense), QPI can now be used to migrate the database.
   
QB-17384: Users were allowed to create folder names which are not allowed in Windows Fixed the issue that it was possible to create a folder with the following charaters  (/,:,*,?,",<,>,|) which are not approved by Windows.
   

 

Known Limitations (1.3.0)

  • Silent installation or upgrade is not available
  • Using the Qlik PostgreSQL Installer on a patched Qlik Sense version can lead to unexpected results. If you have a patch installed, either:
    • Uninstall all patches before using QPI or
    • Upgrade to an IR release of Qlik Sense which supports QPI
  • The summary of Database settings during the upgrade shows not the actual values of the pg_hba.conf
  • Rollback is not available
  • Database size is not checked against free disk space before a backup is taken.
  • Supported are only upgrades of a Qlik Sense Repository Database installed as an embedded Database with the initial installation. You can not upgrade a standalone or QPI converted/installed database.
  • QB-15164: Certain strings and characters cannot be used in the installation with QPI, the command line option for Postgres will not parse them in the command prompt. We have blocked & $ " @ ^ § to be used in the dialogue. If you run into that issue, please change the password to a simpler one before the use of QPI, you can change it back right after the upgrade. (This is anticipated to be fixed in 1.4.0).
  • Windows Server 2012R2 does not support PostgreSQL 14.8. QPI cannot be used on Windows Server 2012R2.

To download the Qlik PostgreSQL installer and review the mandatory documentation, see Upgrading Qlik Sense Repository Database from PostgreSQL 9.6 to 12.5.

 

1.2.0 Release Notes

Improvement / Defect Details
   
SHEND-1106: Support custom install in Qlik PostgreSQL installer It is now possible to select where to install the Postgres Database.
   
SHEND-1066: Add Custom Upgrade  
   
SHEND-1125: Default paths not set in Qlik PostgreSQL installer. Installation and data paths are set to default PostgreSQL paths, instead of default Qlik Sense paths.
   
SHEND-1074: Installation sometimes starts when you navigate forward and back in the installation wizard.  
   
SHEND-1169: Update gradle plugins for new java version  
   
SHEND-1173: Installation fails if the data folder is created inside the installation folder.  

 

Related Content

Upgrading Qlik Sense Repository Database from PostgreSQL 9.6 to 12.5 
Qlik Sense upgrade to November 2022 fails with "An existing standalone PostgresSQL v 12 database has... 

 

Labels (2)
Comments
GeorgeSavu
Contributor II
Contributor II

HI @Sebastian_Linser ,

Any news on when a new version will be released ?

BR,

George 

Version history
Last update:
‎2023-12-20 08:42 AM
Updated by: