Qlik Community

Qlik Alerting Discussions

Ask a question or participate in a discussion about Qlik Alerting here.

Announcements
IMPORTANT: Upcoming LEF Database Maintenance, Oct. 3rd - SEE DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

No e-Mail with set password link after installation

Hello community,

I installed and licensed Qlik Alerting successfully. Unfortunately I have not received the e-mail with the set password link yet. I tried with 'Recover Passwort' - no e-mail with set password link.

On the same machine is NPrinting as well. I used the equal e-mail configuration for Qlik Alerting as we use for NPrinting.

All services are up and running.

Furthermore during e-mail configuration I have not found any button with 'Test Connection'.

 

Do you have any ideas how to solve this topic? @Sunil_Kenth?

Thank you.

Best regards, Patrick

Labels (1)
1 Solution

Accepted Solutions
Highlighted
Employee
Employee

Hi Marc,

Just to clarify on this for other Community members.  In order to receive an alert from Qlik Alerting you need to have a license allocated to the user (Standard or Broadcast) - no license = no alerts.

For testing the mail server configuration through Admin > Channels, there is no license required for this.

Regards,

Sunil

View solution in original post

11 Replies
Highlighted
Employee
Employee

Hi Patrick,

Did you receive a confirmation email saying that the mail server had been configured correctly?  The email would've been sent to the email address you used in the mail server configuration page.

Also, check in the junk folders in case the mail has landed in there.

Thanks,

Sunil

Highlighted
Partner
Partner

Same here. Albeit in my case, I am able to set the email server information, but I am not getting any test email or alert emails

The services for Qlik Alerting are running fine but I don't see any emails in the daemon folders queued, sent, not sent etc.

Nothing in the Junk folder. No confirmation email received after setup either

Highlighted
Partner
Partner

Hello Sunil,

no, did not receive a test e-mail.

Meanwhile Qlik Alerting works. The email configuration was wrong. At the moment I am testing if I receive Alert EMails.

 

Best regards, Patrick

Highlighted
Partner
Partner

@Sunil_Kenth,

no test emails coming through. All license allocations done, all services running, system alerts configured for job failures.

for some reason getting no emails.

Here's the log from email messaging service's daemon folder. Don't know where it is picking up 127.0.0.1 from. COuld that be a setup issue? in the config.json for the services?

Started by default
email-messenger started at 5/11/2020, 8:29:30 AM
PID: 7356. HTTPS Port: 4568
hit /email
hit /email
hit /email
hit /email
Started by default
email-messenger started at 5/11/2020, 9:25:01 AM
PID: 15320. HTTPS Port: 4568
{ Error: connect ECONNREFUSED 127.0.0.1:4561
at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1107:14)
errno: 'ECONNREFUSED',
code: 'ECONNREFUSED',
syscall: 'connect',
address: '127.0.0.1',
port: 4561 }
hit /email
hit /email
hit /email

Highlighted
Employee
Employee

Hi Avastani,

Are you able to successfully test the email server configuration from Admin > Channels?

If so, a confirmation email should be sent to the email address you have used in the 'User Email' field.

Thanks,

Sunil

Highlighted
Partner
Partner

Hi @pwagner 

What I found out that you need to do an additional setting which I believe I did not find in the installation documentation.

When you go to the Qlik Alerting portal click on Admin -> User Management -> License Allocation.

QlikAlertingLicenseAlloc.jpg

Next is to click on Broadcast and assign a license to a user by moving  him from the unassigned to pending (with the right arrow). It will end up in the pending list and after a few moments it will be in the assigned list.

QlikAlertinLicensAllocBroadcast.jpg

I also added the same user to the Standard License type through the same process.

After that my user got the email notifications.

Marc

Highlighted
Partner
Partner

The Test Email functionality definitely does not work.

I am on AWS so I had to permit port 587 for comms to work which is odd, because if all traffic is permitted on outbound, then why would that not work, and use a trusted cert (undocumented how to take a pfx and generate pem and key.pem) so had to dig that up from dependable openssl

Alerts are working now.

 

Highlighted
Partner
Partner

Hello @marcginqo 

 

Thank you for your advice. You are right, this step has not been added to the installation documentation.

In my case all of my recipients has an 'Broadcast license' got. 

I am pretty sure that some settings on the SMTP server are not OK at the moment. In the email-messenger log file I get this error:

 

{ Error: Mail command failed: 421 4.4.2 Message submission rate for this client has exceeded the configured limit

    at SMTPConnection._formatError (C:\Program Files\Qlik Alerting\email-messenger\node_modules\nodemailer\lib\smtp-connection\index.js:784:19)

    at SMTPConnection._actionMAIL (C:\Program Files\Qlik Alerting\email-messenger\node_modules\nodemailer\lib\smtp-connection\index.js:1553:34)

    at SMTPConnection._responseActions.push.str (C:\Program Files\Qlik Alerting\email-messenger\node_modules\nodemailer\lib\smtp-connection\index.js:1035:18)

    at SMTPConnection._processResponse (C:\Program Files\Qlik Alerting\email-messenger\node_modules\nodemailer\lib\smtp-connection\index.js:942:20)

    at SMTPConnection._onData (C:\Program Files\Qlik Alerting\email-messenger\node_modules\nodemailer\lib\smtp-connection\index.js:749:14)

    at TLSSocket.SMTPConnection._onSocketData.chunk (C:\Program Files\Qlik Alerting\email-messenger\node_modules\nodemailer\lib\smtp-connection\index.js:195:44)

    at TLSSocket.emit (events.js:198:13)

    at addChunk (_stream_readable.js:288:12)

    at readableAddChunk (_stream_readable.js:269:11)

    at TLSSocket.Readable.push (_stream_readable.js:224:10)

  code: 'EENVELOPE',

  response:

   '421 4.4.2 Message submission rate for this client has exceeded the configured limit',

  responseCode: 421,

  command: 'MAIL FROM' }

 

Do somebody know this error? If yes, which setting is on the SMTP not OK?

Best regards, Patrick

 

Highlighted
Employee
Employee

Hi Patrick,

Is there a mail server administrator that you can check with?  From doing a quick Google on the error message it seems to be related to a setting on the SMTP server, see here:

https://www.servolutions.com/support/articles/messagesubmissionrate.htm

Regards,

 

Sunil