Skip to main content
Announcements
Qlik Cloud maintenance is scheduled for this weekend May 11-12. View maintenance windows per region here.
cancel
Showing results for 
Search instead for 
Did you mean: 
agigliotti
Partner - Champion
Partner - Champion

Qlik AutoML connection error- FAILED_PRECONDITION

Hi,
I'm facing the below error trying to reload a script with ML deployment.

agigliotti_0-1666969367925.png

[insurance]:
LOAD
[age],
[sex],
[bmi],
[children],
[smoker],
[region],
charges,
RowNo()-1 as [automl_row_index]
FROM [lib://ML:DataFiles/insurance.csv]
(txt, codepage is 28591, embedded labels, delimiter is ',', msq);

[Response_Table]:
LOAD * EXTENSION endpoints.ScriptEval('{"RequestType":"endpoint", "endpoint":{"connectionname":"Qlik_AutoML"}}', insurance);

I really don't understand why sometimes it works successfully and sometimes it does not with the above error.

Could someone help me to fix it?

Many thanks in advance for your time.

Best Regards

Labels (2)
1 Solution

Accepted Solutions
Kyle_Jourdan
Employee
Employee

@agigliottiand @KellyHobson 

The engineering team has identified and corrected the issue.

You should be receiving responses from the real-time API successfully now.

View solution in original post

3 Replies
KellyHobson
Former Employee
Former Employee

Hey @agigliotti ,

Thanks for reaching out on the forum. 

I looked up your error id on our internal search engine and see a 'Connection closed' message on the node it was run on. 

How often do you see this message?  

Are you using the ML connector to predict against new records ('fetched 1338') ?

When it does complete successfully, approximately how long does it take to complete?

Thank you,

Kelly 

 

 

Kyle_Jourdan
Employee
Employee

@agigliottiand @KellyHobson 

The engineering team has identified and corrected the issue.

You should be receiving responses from the real-time API successfully now.

agigliotti
Partner - Champion
Partner - Champion
Author

Hi @Kyle_Jourdan ,

It seems to be working now.

Great job!