Qlik Community

Qlik Brasil

Welcome to the group for Brazil users. .All discussions will be in Portuguese.

Highlighted
Not applicable

API Geocode GoogleMaps V4

Boa tarde.

Possuo um Job que consome a API go Google, pra georeferenciar me Base, e gera os QVD´s com os dados, porém, desde a semana passada, está dando erro de Acesso Negado.

Alguém está passando por este problema também?

Meu código está desta forma:

Latitude_Longitude:

  LOAD $(a) as RowNo,

  replace([result/geometry/location/lat], '.', ',') as LATITUDE,

      replace([result/geometry/location/lng], '.', ',') as LONGITUDE

  FROM [http://maps.googleapis.com/maps/api/geocode/xml?address=$(VCEP)&sensor=false] (XmlSimple, Table is [GeocodeResponse]);

Quando eu coloco o endereço do serciço no Browser e altero a variável VCEP para um CEP válido, retorna o XML certinho, mas pelo Qilk está dando Acesso Negado.

Obrigado pela ajuda.

Renato Adolfs

1 Solution

Accepted Solutions

Re: API Geocode GoogleMaps V4

Legal!

Então feche o post com as respostas que mais te ajudaram.

Apenas uma correção: A versão da API é v3

8 Replies

Re: API Geocode GoogleMaps V4

Pode disponibilizar a mensagem de erro?

Not applicable

Re: API Geocode GoogleMaps V4

Obrigado pela resposta, Yuri.

Esta é a evidência do erro:

erro_geocode.png

Re: API Geocode GoogleMaps V4

Renato, você consegue acessar essa URL, com um navegador, utilizando esse mesmo usuário neste mesmo computador?

Not applicable

Re: API Geocode GoogleMaps V4

Consigo sim, Yuri:

erro_geocode.png

Estava funcionando normalmente até duas semanas atrás.

Existe alguma forma de eu fixar os dados de autenticação no script do Qlik?

Obrigado pela atenção,

Renato Adolfs

Re: API Geocode GoogleMaps V4

Pode ser que seja falta da chave de utilização.

Tente adicionar uma chave de utilização da API através do parâmetro KEY.

Para maiores informações: The Google Geocoding API   |   Google Maps Geocoding API   |   Google Developers

Not applicable

Re: API Geocode GoogleMaps V4

Yuri, resolvemos o problema.

Se tratava de um bloqueio no proxy.

Muito obrigado pela atenção,

Renato Adolfs

Re: API Geocode GoogleMaps V4

Legal!

Então feche o post com as respostas que mais te ajudaram.

Apenas uma correção: A versão da API é v3

Not applicable

Re: API Geocode GoogleMaps V4

Obrigado, Yuri.

Abraços.