Qlik Community

Qlik Brasil

Group community for Brazil users. discussion only in Portuguese.

Highlighted
Not applicable

Botão não Funciona

Bom tarde a todos,

Estou com um problema aparentemente simples... Fiz 2 mapas e soprepus  um em cima do outro, posteriormente coloquei 2 Botões,

Um interligado em cada mapa com seu ID Objeto, fazendo então que em cada clique aparecesse determinada coisa no botão e está funcionando... porém ao publicar isso no meu performance, os botões não funcionam, não é possível "clicá-los", alguma ideia???

Obrigado pela atenção de vocês.

Tags (1)
6 Replies
aderlanrm
Not applicable

Re: Botão não Funciona

Olá Leonardo,

Você usou macro (módulo) nesses botões?

Se sim, é esse o "problema", você deve liberar o uso de macros no server, o que NÃO é recomendado, dependendo da funcionalidade, dê preferencia para usar as funções que está na lista de ações do QlikView, mas se é uma funcionalidade muito importante, faça as devidas permissões no server que vai funcionar.

Abraço.

Not applicable

Re: Botão não Funciona

Aderlan,

Eu não usei macro, nos dois botões apenas utilizei a ação "Ativar Objetos", funcionalidade do própio Qlikview,

Alguma outra ideia?

Obrigado de qualquer forma,

Abraço

erich_shiino
Not applicable

Re: Botão não Funciona

Estes botões podem estar atrás de uma parte transparente do gráfico ou de outro elemento como uma caixa de texto?

Estou imaginando que o server pode estar se confundindo com objetos na mesma camada e deixando seus botões atrás de outra coisa.

Pode forçar que os botões fiquem em camadas superiores ( como se estivessem mais próximos ao usuário... )

Para isto, selecione os botões, entre em propriedades, layout e altere layer/camada para top/superior ou coloque custom e defina um valor elevado ( por exemplo, 50)

Espero que ajude

Abs,

Erich

aderlanrm
Not applicable

Re: Botão não Funciona

Pode anexar um arquivo de exemplo para darmos uma olhada?

Not applicable

Re: Botão não Funciona

Leonardo,

você está usando Ajax ou Plugin?

se tiver usando Ajax recomendo instalar o plugin só pra vê se o problema é no ajax.

Espero ter ajudado,

Gleybson Fernandes

Not applicable

Re: Botão não Funciona

Segunda-Feira eu mando o link QlikView pra vocês olharem,

Pegarei a permissão do meu chefe neste dia,

Grato efetivamente pela atenção de todos!!

Att, Leonardo