Qlik Community

Qlik Brasil

Group community for Brazil users. discussion only in Portuguese.

Highlighted
brunoabdante
New Contributor II

Erro ao carregar grande volume de dados

Boa tarde pessoal!

Novamente vou precisar da ajuda de vocês rs!

Seguinte, estava com dificuldades em criar uma conexão com um banco SQLite que possuo aqui, consegui acessa-lo criando uma conexão de usuário DSN, ponto resolvido, mas quando tento subir esses dados para o Qlik Sense ele apresentado o seguinte erro:

Connector reply error: SQL##f - SqlState: S1000, ErrorCode: 7, ErrorMsg: unknown error (7).

Alguem já teve algum problema parecido?  A base que estou tentando subir é relativamente grande + de 7 milhões de registros.

Muito obrigado novamente!

Abraços,

Bruno Greco Abdante

Tags (1)
2 Replies
MVP
MVP

Re: Erro ao carregar grande volume de dados

Bruno,

7 milhões não são um grande volume (claro que depende da sua maquina).  Podes mandar o log da carga?  Qual o SELECT que fizestes?

brunoabdante
New Contributor II

Re: Erro ao carregar grande volume de dados

Olá Alessandro!

Primeiro, desculpe a demora em responder ....

Certo, não sabe o alivio que tive ao ver o que escreveu "que não são um grande volume", pois estava preocupado em que o Sense não aceitasse uma quantidade dessa de registros, pois esse volume que mencionei vai se multiplicar com o decorrer do tempo.

Sobre o problema em si eu "dei um jeito" e foi, para explicar melhor eu fiz o seguinte: Fiz o import por script de cada um dos campos individualmente e para minha supresa foi, em seguida para solucionar o problema momentaneamente eu fiz varios scripts impotando alguns campos por vez. Não tenho sombra de duvidas de que não é a melhor solução, mas funcionou por enquanto.

Sobre o log (até me desculpe) eu não sei onde posso pega-lo, poderia me auxiliar para que eu te envie?

O SELECT fiz algo bem simples mesmo (o script abaixo é somente para um campo):

LIB CONNECT TO 'SQLite Sinistros 3';

[Sinistros]:

LOAD

    [NRO_APOLICE],

    [ID];

   

SQL SELECT

    "NRO_APOLICE",

    "ID"

FROM "Sinistros";


Não faço ideia do que possa ter acontecido rs. Mas sem duvidas quero soluciona-lo para efetuar uma carga correta dos dados.

Obs.: De forma alguma consigo abrir o Data Manager, também não sei o motivo.

Muito obrigado!

Abs